Bug 457501 - Firefox unable to load mail.yahoo.com after java, libxslt updates on 2008/07/31
Firefox unable to load mail.yahoo.com after java, libxslt updates on 2008/07/31
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
i386 Linux
low Severity high
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 01:04 EDT by De-Wei Yin
Modified: 2008-08-01 10:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 10:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description De-Wei Yin 2008-08-01 01:04:34 EDT
Description of problem:

After the following RHEL 5.2 packages (listed in /var/log/up2date) were updated
on 2008/07/31, Firefox (firefox-3.0.1-1.el5) is unable to open email at
mail.yahoo.com.  There was no problem opening email at mail.yahoo.com prior to
these upgrade.

[Thu Jul 31 13:28:07 2008] up2date Adding packages to package profile:
['java-1.5.0-ibm-1.5.0.8-1jpp.1.el5', 'java-1.5.0-ibm-demo-1.5.0.8-1jpp.1.el5',
'java-1.5.0-ibm-devel-1.5.0.8-1jpp.1.el5',
'java-1.5.0-ibm-javacomm-1.5.0.8-1jpp.1.el5',
'java-1.5.0-ibm-jdbc-1.5.0.8-1jpp.1.el5',
'java-1.5.0-ibm-plugin-1.5.0.8-1jpp.1.el5',
'java-1.5.0-ibm-src-1.5.0.8-1jpp.1.el5', 'libxslt-1.1.17-2.el5_2.2',
'libxslt-devel-1.1.17-2.el5_2.2', 'libxslt-python-1.1.17-2.el5_2.2',
'nfs-utils-1.0.9-35z.el5_2']

Version-Release number of selected component (if applicable):

firefox-3.0.1-1.el5 (installed on 2008/07/16)
RPM packages listed above

How reproducible:

Always (every time since the above updates were applied).

Steps to Reproduce:
1. Open http://mail.yahoo.com/, Firefox successfully loads login page
2. Enter user ID and password, press enter.
3. Firefox unable to load subsequent page, Firefox view area is blank, and the
blue "loading" cursor just keeps on spinning forever (until I click on the
"stop" button several minutes later to abort it).
  
Actual results:

Firefox stalls and does not finish loading Yahoo email.  The blue circular
cursor spins forever.

Expected results:

Firefox shows Yahoo email summary, Inbox and other folders, as it had been
working on 2008/07/30, before the above updates were applied.

Additional info:

I also had Firefox 2.0.0.11 installed on the system, so I tried Firefox 2.0.0.11
and it also did not work.
Comment 1 Radek Bíba 2008-08-01 09:35:54 EDT
Works fine here:
$ rpm -q firefox java-1.5.0-ibm-plugin
firefox-3.0.1-1.el5
java-1.5.0-ibm-plugin-1.5.0.8-1jpp.1.el5
$ readlink /etc/alternatives/libjavaplugin.so
/usr/lib/jvm/jre-1.5.0-ibm/bin/libjavaplugin_ojigtk2.so

Did only mail.yahoo.com stop working for you, or all java applets? Also, are you
sure the Yahoo! webmail application uses java? I can't find any indication of
that on the subsequent page or in its html source.
Comment 2 Radek Bíba 2008-08-01 09:42:24 EDT
I might also add that I'm running libxslt-1.1.17-2.el5_2.2, too (which is a
package required by Firefox). Still, I can read my Yahoo! e-mails just fine.
Comment 3 De-Wei Yin 2008-08-01 09:50:18 EDT
Radek,

I appreciate Your quick response.  Let me see whether I can get some help on my
end to further narrow down or eliminate some factors.

Dewey
Comment 4 Matěj Cepl 2008-08-01 09:51:47 EDT
I am almost certain that mail.yahoo.com doesn't use java at all -- I have it now
running (including embedded Messenger) and no java process is running.
Comment 5 Matěj Cepl 2008-08-01 09:53:04 EDT
Do you see anything in console when running firefox from the gnome-terminal?
Comment 6 De-Wei Yin 2008-08-01 10:04:50 EDT
Radek, Matej,

I just tried connecting to Yahoo Mail through a proxy using SSH tunneling and it
now works.  The proxy is on a different network, so the person helping me thinks
it's a network problem.  I also had problems connecting some other websites,
such as www.library.utexas.edu, www.thestar.com, but no problem now through the
proxy.

There is no message in the console either when Firefox stalls on the direct
connection or connects successfully through the proxy.

Let's close this issue.  I'm sorry to have wasted Your time and very much
appreciate the help.

Dewey
Comment 7 Matěj Cepl 2008-08-01 10:36:00 EDT
No problem, that's our job. I hope you'll find how to make it work for you.

Note You need to log in before you can comment on or make changes to this bug.