Bug 457524 - Automounter does not work in the diskless environment
Automounter does not work in the diskless environment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On: 450646
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 06:58 EDT by Ondrej Valousek
Modified: 2010-10-22 23:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Valousek 2008-08-01 06:58:29 EDT
Description of problem:
Automounter does not work when /etc is mounted read-only

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Solution is known - Ian has it...
Comment 1 RHEL Product and Program Management 2008-08-01 11:10:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Ondrej Valousek 2008-08-02 05:02:36 EDT
Eventually, this seems to be a bug in nfs-utils (see bug #450646) and not in
autofs. /bin/mount command already handles this and /sbin/mount.* should as
well. I believe there is no need to patch autofs once nfs-utils are patched.
Ondrej
Comment 12 errata-xmlrpc 2009-01-20 16:45:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0178.html

Note You need to log in before you can comment on or make changes to this bug.