Bug 457534 - perl-Catalyst-Manual does not provide perl(Catalyst::Manual)
perl-Catalyst-Manual does not provide perl(Catalyst::Manual)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Catalyst-Manual (Show other bugs)
9
All All
low Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 07:57 EDT by Emmanuel Seyman
Modified: 2008-08-26 21:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.07-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 21:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Seyman 2008-08-01 07:57:56 EDT
Description of problem:
I'm hitting an error trying to update my system on which the perl-Catalyst-*
modules are installed.

It looks like the perl-Catalyst-Manual rpm doesn't actually provide
perl(Catalyst::Manual) and this is causing yum to fail.

[manu@orient ~]$ LANG=C sudo yum provides "perl(Catalyst::Manual)"
perl-Catalyst-Manual-5.700701-3.fc9.noarch : Catalyst web framework manual
Matched from:
Other       : perl(Catalyst::Manual)

[manu@orient ~]$ LANG=C sudo yum info perl-Catalyst-Manual
Available Packages
Name       : perl-Catalyst-Manual
Arch       : noarch
Epoch      : 1
Version    : 5.7013
Release    : 1.fc9

Note the difference between the version numbers.

Version-Release number of selected component (if applicable):
5.7013-1.fc9

How reproducible:


Steps to Reproduce:
1. Run the command "yum update"
2. yum fails, unable to update perl-Catalyst-Devel due to a missing dependency

  
Actual results:
The yum transaction aborts because it cannot find "perl(Catalyst::Manual)"

Expected results:
All rpms on the system should be updated.
Comment 1 Fedora Update System 2008-08-07 19:51:49 EDT
perl-Catalyst-Devel-1.07-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.