Bug 457553 - ath5k brings up wlan0 but it can't scan for ESSIDs or connect
ath5k brings up wlan0 but it can't scan for ESSIDs or connect
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 10:09 EDT by Giovanni Cucca
Modified: 2008-08-01 10:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 10:23:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giovanni Cucca 2008-08-01 10:09:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/4.1; Linux) KHTML/4.1.0 (like Gecko) Fedora/4.1.0-2.fc9

Description of problem:
Though wlan0 is brought up normally, it seems to be unable to find or scan for
any network. If I try to connect to known ESSIDs, it does nothing. When I try to
disable and reactivate wireless in NetworkManager, I get this output in
/var/log/messages:
Aug  1 15:40:11 sincity NetworkManager: <info>  (wlan0): device state change: 3
-> 2
Aug  1 15:40:11 sincity NetworkManager: <info>  (wlan0): deactivating device.
Aug  1 15:40:11 sincity NetworkManager: <info>  (wlan0): taking down device.
Aug  1 15:40:18 sincity NetworkManager: <info>  (wlan0): bringing up device.
Aug  1 15:40:18 sincity kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  1 15:40:18 sincity NetworkManager: <info>  (wlan0): device state change: 2
-> 3

With the kernel from the install dvd, version 2.6.25-14 , it all worked like a
charm, but not with 2.6.25.10-86 and 2.6.25.11-97

Version-Release number of selected component (if applicable):
kernel-2.6.25.11-97.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1.Boot up (or disable and enable wireless)
2.scan for ESSIDs or connect to a known ESSID			
3.

Actual Results:
nothing

Expected Results:
It should have found some networks and connect to kwown networks

Additional info:
Wireless card model:

[root@sincity ~]# lspci | grep Atheros
06:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg
Wireless PCI Express Adapter (rev 01)
Comment 1 John W. Linville 2008-08-01 10:23:48 EDT

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.