Bug 457570 - Printer will not print at all
Printer will not print at all
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 11:23 EDT by Paul Finnigan
Modified: 2008-08-02 07:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-02 07:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshoot.txt for gutenprint driver and test page (302.04 KB, text/plain)
2008-08-01 14:38 EDT, Paul Finnigan
no flags Details

  None (edit)
Description Paul Finnigan 2008-08-01 11:23:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
My printer (a Canon PIXMA ip5200, I know I should not use Canon but I like it) has stopped working with my desktop machine. This happened about six weeks ago, around the time I configured Samba, but I do not know if this is related. It is connected directly to my Fedora 9 desktop and all this relates to just attempting to print directly from my desktop system.

Installed software that could be relavant (I update on a regular basis but only use Test repositories when I have a problem):

samba.i386		3.2.0-2.17.fc9
samba-client.i386	3.2.0-2.17.fc9
samba-common.i386	3.2.0-2.17.fc9
samba-swat.i386		3.2.0-2.17.fc9
samba-winbind.i386	3.2.0-2.17.fc9

cups.i386		1:1.3.7-8.fc9
cups-libs.i386		1:1.3.7-8.fc9
cups-lpd.i386		1:1.3.7-8.fc9
cups-pdf.i386		2.4.8-1.fc9
cupsddk.i386		1.2.3-4.fc9
cupsddk-drivers.i386	1.2.3-4.fc9

turboprint-2.00-1.i586.rpm

I have tried both turoprint drivers and gutenprint drivers. I have even upgraded turboprint to see if that helps.

Documents used to print:
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/Global_File_System.pdf
Read into firefox and Adobe Reader and first page printed direct
Saved locally and printed from Envince and Adobe Reader
I have tried lots of others but these allow me a controlled test as I make changes.

Simple text file created which read "test print" on just one line and printed from gedit.

The result is always a warning that the printer may not be connected.

I can print from my fedora 9 laptop without problems. The difference? The differences are small but the laptop does not run Samba and a couple of other services but they are built from almost the same scripts. 

Just to make sure that it is not seen as a samba printer problem I am not using samba to print, just using the local printer. Samba does make that available but I do not use it at present. I am not saying that Samba is not causing the problem and stopping samba does not fix it.

There appears to be no great pointers to me. Can anyone help.

Thanks in anticipation

Version-Release number of selected component (if applicable):
cups.i386	-1:1.3.7-8.fc9

How reproducible:
Always


Steps to Reproduce:
1.Print a document
2.
3.

Actual Results:
Nothing

Expected Results:
The document should have printed.

Additional info:
Problem details:

1. Log when printer is switched on:

Aug  1 15:48:11 localhost kernel: usb 3-1.4: new full speed USB device using uhci_hcd and address 5
Aug  1 15:48:11 localhost kernel: usb 3-1.4: not running at top speed; connect to a high speed hub
Aug  1 15:48:11 localhost kernel: usb 3-1.4: configuration #1 chosen from 1 choice
Aug  1 15:48:11 localhost kernel: usb 3-1.4: New USB device found, idVendor=04a9, idProduct=10a5
Aug  1 15:48:11 localhost kernel: usb 3-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug  1 15:48:11 localhost kernel: usb 3-1.4: Product: iP5200
Aug  1 15:48:11 localhost kernel: usb 3-1.4: Manufacturer: Canon
Aug  1 15:48:11 localhost kernel: usb 3-1.4: SerialNumber: 614668
Aug  1 15:48:11 localhost kernel: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04A9 pid 0x10A5
Aug  1 15:48:11 localhost kernel: usbcore: registered new interface driver usblp
Aug  1 15:49:03 localhost gconfd (root-4685): starting (version 2.22.0), pid 4685 user 'root'
Aug  1 15:49:03 localhost gconfd (root-4685): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Aug  1 15:49:03 localhost gconfd (root-4685): Resolved address "xml:readwrite:/root/.gconf" to a writable configuration source at position 1
Aug  1 15:49:03 localhost gconfd (root-4685): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position

2. cups access_log shows:

localhost - - [01/Aug/2008:15:48:12 +0100] "POST / HTTP/1.1" 200 327 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:48:12 +0100] "POST / HTTP/1.1" 200 129 CUPS-Get-Classes successful-ok
localhost - - [01/Aug/2008:15:51:45 +0100] "POST / HTTP/1.1" 200 416 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:51:45 +0100] "POST / HTTP/1.1" 200 416 CUPS-Get-Classes successful-ok
localhost - - [01/Aug/2008:15:51:45 +0100] "POST / HTTP/1.1" 200 75 CUPS-Get-Default successful-ok
localhost - - [01/Aug/2008:15:51:45 +0100] "POST / HTTP/1.1" 200 112 CUPS-Get-Default successful-ok
localhost - - [01/Aug/2008:15:51:45 +0100] "POST /printers/ HTTP/1.1" 200 204 CUPS-Get-Printers successful-ok

3. Print page 1 of the pdf using evince

4. The cups access_log shows:

localhost - - [01/Aug/2008:15:55:09 +0100] "POST / HTTP/1.1" 200 312 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:09 +0100] "GET /ppd/tp0.ppd HTTP/1.1" 200 37353 - -
localhost - - [01/Aug/2008:15:55:12 +0100] "POST / HTTP/1.1" 200 312 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:14 +0100] "POST /printers/tp0 HTTP/1.1" 200 58655 Print-Job successful-ok
localhost - - [01/Aug/2008:15:55:14 +0100] "POST / HTTP/1.1" 200 178 Get-Jobs successful-ok
localhost - - [01/Aug/2008:15:55:14 +0100] "POST / HTTP/1.1" 200 323 Create-Printer-Subscription successful-ok
localhost - - [01/Aug/2008:15:55:14 +0100] "POST / HTTP/1.1" 200 178 Get-Jobs successful-ok
localhost - - [01/Aug/2008:15:55:14 +0100] "POST / HTTP/1.1" 200 327 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:15 +0100] "POST / HTTP/1.1" 200 153 Get-Notifications successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "POST /printers/ HTTP/1.1" 200 346 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "POST /printers/ HTTP/1.1" 200 346 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "POST / HTTP/1.1" 200 203 Get-Printer-Attributes successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "GET /ppd/Cups-PDF.ppd HTTP/1.1" 200 20940 - -
localhost - - [01/Aug/2008:15:55:16 +0100] "POST /printers/ HTTP/1.1" 200 346 CUPS-Get-Printers successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "POST / HTTP/1.1" 200 198 Get-Printer-Attributes successful-ok
localhost - - [01/Aug/2008:15:55:16 +0100] "GET /ppd/tp0.ppd HTTP/1.1" 200 37353 - -
localhost - - [01/Aug/2008:15:55:17 +0100] "POST /printers/ HTTP/1.1" 200 374 Get-Printer-Attributes successful-ok
localhost - - [01/Aug/2008:15:55:17 +0100] "POST /printers/ HTTP/1.1" 200 302 Get-Jobs successful-ok....

5. The cups error_log shows:

I [01/Aug/2008:15:55:14 +0100] [Job 36] Adding start banner page "none".
I [01/Aug/2008:15:55:14 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:14 +0100] [Job 36] Adding job file of type application/postscript.
I [01/Aug/2008:15:55:14 +0100] [Job 36] Adding end banner page "none".
I [01/Aug/2008:15:55:14 +0100] [Job 36] Queued on "tp0" by "paul".
I [01/Aug/2008:15:55:14 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:14 +0100] [Job 36] Started filter /usr/lib/cups/filter/pstops (PID 4712)
I [01/Aug/2008:15:55:14 +0100] [Job 36] Started filter /usr/lib/cups/filter/pstoturboprint (PID 4713)
I [01/Aug/2008:15:55:14 +0100] [Job 36] Started backend /usr/lib/cups/backend/usb (PID 4714)
I [01/Aug/2008:15:55:14 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:14 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:14 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:26 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:27 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:27 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:27 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:55:27 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:56:36 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:56:36 +0100] Saving subscriptions.conf...
I [01/Aug/2008:15:56:36 +0100] [Job 36] Canceled by "paul".

6. The system log then shows:

Aug  1 15:56:37 localhost setroubleshoot: SELinux is preventing tpstdin (cupsd_t) "write" to ./print.log (var_log_t). For complete SELinux messages. run sealert -l 45626c9f-887c-4a79-8c9e-cef1e40fdd91

but I am running SELinux in permissive mode and this is about me cancelling the print job anyway.
Comment 1 Tim Waugh 2008-08-01 11:34:52 EDT
Please use the trouble-shooter: System->Administration->Printing, then select
Help->Troubleshoot.

Attach the resulting troubleshoot.txt file here using the link below.  Thanks.
Comment 2 Paul Finnigan 2008-08-01 14:38:50 EDT
Created attachment 313220 [details]
troubleshoot.txt for gutenprint driver and test page
Comment 3 Tim Waugh 2008-08-02 05:28:13 EDT
It looks like the permissions on /dev/usb/lp0 are incorrect.  The group should
be 'lp', but it is 'usb' (which isn't a group that exists on my Fedora 9
installation, at least).

{'getfacl_output': [('/dev/usb/lp0',
                     ['# file: dev/usb/lp0',
                      '# owner: root',
                      '# group: usb',
                      'user::rw-',
                      'group::rw-',
                      'other::---'])]}

What does '/usr/sbin/lpinfo -v' say when your printer is connected and switched on?
Comment 4 Paul Finnigan 2008-08-02 06:48:14 EDT
[paul@ewing ~]$ /usr/sbin/lpinfo -v
network socket
network beh
direct
hal:///org/freedesktop/Hal/devices/usb_device_4a9_10a5_614668_if0_printer_noserial
file cups-pdf:/
direct hpfax
direct hp
network http
network ipp
network lpd
direct scsi
serial serial:/dev/ttyS0?baud=115200
network smb
[paul@ewing ~]$ 
Comment 5 Paul Finnigan 2008-08-02 07:34:38 EDT
Tim

I have found the problem! You are correct about group usb. 

I created it to get usb devices working on VirtualBox. I had thought that I had
tidied up after myself. Removing my udev rule that put devices into this group
has solved the problem.

Apologies for wasting your time. 

I have closed it off as not a bug, a very nice way to say that it was my own
stupid fault.

Note You need to log in before you can comment on or make changes to this bug.