Bug 457600 - unopkg loops installing openoffice.org-presenter-screen in the presence of openoffice.org-langpack-es
unopkg loops installing openoffice.org-presenter-screen in the presence of op...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 15:11 EDT by Alexandre Oliva
Modified: 2008-08-05 06:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 06:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2008-08-01 15:11:40 EDT
yum was taking forever (really) to complete on several machines, x86_64 and
i686, the last 2 or 3 builds of OOo for rawhide.

I killed unopkg that had been running for several hours, and then eventually it
completed.

Then I tried to reinstall the package by hand:

# rpm -Uv --replacepkgs
openoffice.org-presenter-screen-3.0.0-0.0.28.1.fc10.x86_64.rpm

ERROR: There is no such extension deployed: com.sun.PresenterScreen-linux_x86_64

unopkg failed.
openoffice.org-presenter-screen-3.0.0-0.0.28.1.fc10
13190 pts/13   T      0:00 /bin/sh /usr/lib64/openoffice.org3/program/unopkg add
--shared --link /usr/lib64/openoffice.org/extensions/presenter-screen.oxt
13220 pts/13   Tl     0:15 /usr/lib64/openoffice.org3/program/unopkg.bin add
--shared --link /usr/lib64/openoffice.org/extensions/presenter-screen.oxt
-env:JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY=1
-env:UserInstallation=file:///tmp/unoinstall.OBqsFH
-env:INIFILENAME=vnd.sun.star.pathname:/usr/lib64/openoffice.org3/program/redirectrc

# strace -p 13220
read(0, ""..., 4096)                    = 0
write(1, "\n\nLa entrada es incorrecta. Escri"..., 50) = 50
[repeats ad nauseum]

(no) input is from a pipe, output is to /dev/null.  For some reason, it's in
Spanish, meaning “The entry is incorrect.  Write "yes" or "no".”.  My default
language is en_US.UTF-8, but I do have openoffice.org-langpack-es installed. 
Removing it enables installation to complete successfully, and then reinstalling
the langpack succeeds.  But then, if I try to reinstall the presenter package,
to confirm the diagnostic, the problem is back.
Comment 1 Caolan McNamara 2008-08-01 19:38:55 EDT
oh man, the damn license agreement rubbish must be localized to take the
localized versions of yes or no
Comment 2 Caolan McNamara 2008-08-03 12:04:32 EDT
should be fixed in the next spin
Comment 3 Caolan McNamara 2008-08-05 06:10:30 EDT
Should be ok in 3.0.0-0.28-2, the previous 3.0.0-0.28-1 may warn about "not being installed" on being updated, but the newly installed 3.0.0-0.28-2 should "just work" and no problems thereafter.

Note You need to log in before you can comment on or make changes to this bug.