Bug 457623 - lpr: Error - no default destination available.
lpr: Error - no default destination available.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 16:30 EDT by Gene Czarcinski
Modified: 2008-08-01 17:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 16:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2008-08-01 16:30:59 EDT
Description of problem:
This is probably a dup of https://bugzilla.redhat.com/show_bug.cgi?id=455003

On one of my Fedora 9 x86_64 systems, I started getting the error message in the
Summary ... on another system with the same updates, things work just fine.

This did not start until the last week or so (before that it worked fine and as
best I can remember, I did not change the printer configuration).

On both working and not-working systems, the printers were configured with the
system-config-printer gui.  There are two postscript printers: an HP4000
Laserjet as lp0 (LPD interface) and an HP 2550 ColorLaserjet as lp1.  Default
printer is lp0.

I have tried deleting and then reinstalling the printers, changing the default
from lp0 to lp1, but nothing works.

Although the problem occurred with a locally written program (which has a
fork(), execvp(lpr), and passes data via a pipe), I have gotten it to reproduce
with just "lpr".  Specifying a printer works fine and the output prints.

Using firefox to print works with no problem.

For whatever it is worth, I get the same error with "lp" and "lpr".


Version-Release number of selected component (if applicable):
Fedora 9 with (more or less) current updates

How reproducible:
yes ... on the system where it is broken.  On another Fedora 9 x86_64 system
with the same updates, it works fine.
Comment 1 Gene Czarcinski 2008-08-01 16:50:13 EDT
Oops.  I am closing this because the problem MUST BE something on my end!!

I have now verified that the problem only occurs with one userid (???)
Comment 2 Tim Waugh 2008-08-01 17:15:53 EDT
Sounds like all the other users have a 'personal default' printer, i.e. set with
the equivalent of 'lpoptions', but there is no system default printer (which you
can set with system-config-printer).

Note You need to log in before you can comment on or make changes to this bug.