Bug 457638 - logging out of login manager error "...kdm --lang en_US' not found."
logging out of login manager error "...kdm --lang en_US' not found."
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 468607 (view as bug list)
Depends On: 468889
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-02 01:21 EDT by Claude Jones
Modified: 2008-11-05 09:01 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 08:19:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stderr.log (13.28 KB, text/plain)
2008-08-03 16:41 EDT, Sterling Winter
no flags Details

  None (edit)
Description Claude Jones 2008-08-02 01:21:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

Description of problem:
"Command '/usr/bin/kcmshell4 kdm --lang en_US' not found."

When running systemsettings from the menu, and I click on the advanced tab and select 'Login Manager' I get the above error when I try to exit that window. This happens every time I open that window. US English (eng_US) is what's selected for my language

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Open Systemsettings from the KDE menu
2.Click on the advanced tab
3.Click on login manager
4.Adjust any parameter then close the window

Actual Results:


Expected Results:


Additional info:
Comment 1 Colin J Thomson 2008-08-02 08:27:29 EDT
This seems only to happen from System Settings on this F9 Box.
I have just ran this from a Konsole as sudo and user
/usr/bin/kcmshell4 kdm --lang en_GB

And the above error does not appear. I'll test some more later.
Comment 2 Sterling Winter 2008-08-02 20:21:01 EDT
I'm up to date with the KDE 4.1 packages from updates-testing, and I didn't experience this bug at all until immediately after I installed kdepim-4.1.0-2.fc9.i386 and kdeutils-4.1.0-1.fc9.2.i386 from kde-redhat's unstable repo.
Comment 3 Florian Sievert 2008-08-03 05:08:33 EDT
I cannot confirm comment #2 with kde-testing and the two packages from kde-unstable. The problem still exist here, so the solution might be related to something else.
Comment 4 Sterling Winter 2008-08-03 06:30:26 EDT
(In reply to comment #3)
I can confirm it with a fair certainty. I just performed the following:
1. Logged into KDE
2. Launched System Settings --> Advanced --> Login Manager
3. Authenticated as root, then when the Login Manager came up, clicked Cancel
4. The errant KDE su dialog appeared
5. Closed the dialog, removed the aforementioned kdepim-4.1.0-2.fc9.i386 and downgraded kdeutils-4.1.0-1.fc9.2.i386 (from kde-redhat unstable) to kdeutils-4.1.0-1.fc9.1.i386 (from fedora updates-testing)
6. Logged out of KDE
7. Repeated steps 1-3
8. The errant KDE su dialog no longer appeared; problem solved

So it looks like something in kdeutils from kde-redhat unstable is indeed causing the KDE su dialog problem, at least for me.
Comment 5 Sterling Winter 2008-08-03 07:59:59 EDT
I don't know anything about how KDE services start up, but could this be related to KWallet? The kdelibs-4.1.0-4.fc9.i386 package from updates-testing (also kde-testing) installs a /usr/share/kde4/services/kwalletd.desktop that's not present in 4.0.5, although KWallet itself is in kdeutils, not kdelibs.
Comment 6 Sterling Winter 2008-08-03 08:42:23 EDT
Ok scratch my KWallet theory. It doesn't matter which version of kdeutils I have installed (4.1.0-1.fc9.1.i386 or 4.1.0-1.fc9.2.i386), if kdepim isn't also installed there's no bug. And if only kdepim-libs is present without kdepim, there's still no bug. But once I install the main kdepim package, then the bug appears. This doesn't make any sense to me, but there it is.
Comment 7 Colin J Thomson 2008-08-03 09:36:04 EDT
Yes I can confirm removing kdepim4 this error stops. 
But why does it work OK *with* kdepim4 installed when I issue:
sudo /usr/bin/kcmshell4 kdm --lang en_GB from a Konsole.

kdepim-4.1.0-2.fc9.i386
kdepimlibs-4.1.0-1.fc9.i386
kdepim-libs-4.1.0-2.fc9.i386
Comment 8 Sterling Winter 2008-08-03 15:23:30 EDT
(In reply to comment #7)
> Yes I can confirm removing kdepim4 this error stops. 
> But why does it work OK *with* kdepim4 installed when I issue:
> sudo /usr/bin/kcmshell4 kdm --lang en_GB from a Konsole.

I don't have experience with KDE under the hood so I'm just shooting in the dark again: Since kdepim doesn't appear to install anything that overlaps in functionality with the Login Manager's system settings panel, is it possible one of kdepim's update scripts in /usr/share/kde4/apps/kconf_update is being overzealous and writing to a file it shouldn't be? Or perhaps an eager `grep -i -e` in the specfile? Anyone know how to record all file writes performed by a live rpm install (as opposed to `rpm -qlp` which merely lists what the rpm is *supposed* to write)?

> kdepim-4.1.0-2.fc9.i386
> kdepimlibs-4.1.0-1.fc9.i386
> kdepim-libs-4.1.0-2.fc9.i386

Hm, what's "kdepimlibs"? Typo?
Comment 9 Colin J Thomson 2008-08-03 15:39:59 EDT
No typo; that is what was listed with rpm -qa|grep kdepim

kdepim - PIM (Personal Information Manager) applications
kdepimlibs - K Desktop Environment 4 - PIM Libraries
kdepim-libs - kdepim runtime libraries
Comment 10 Sterling Winter 2008-08-03 16:41:06 EDT
Created attachment 313296 [details]
stderr.log

Log of stderr when launching Login Manager from the console with `/usr/bin/kcmshell4 kdm --lang en_US` then clicking Cancel.

Finally found a correlation between kdepim and Login Manager here. In the error log you'll see some strigi libs listed, and three of those libs are ones updated by installation of kdepim:

/usr/lib/strigi/strigiea_ics.so
/usr/lib/strigi/strigiea_rfc822.so
/usr/lib/strigi/strigiea_vcf.so

So it seems kdepim introduced something into those libs which causes an error with Login Manager and the Login Manager launcher in Systems Settings may not trap the error properly, treating it too simply as "command not found".
Comment 11 Sterling Winter 2008-08-04 16:51:50 EDT
This one's tricky. kdepim's strigiea_ics.so, strigiea_rfc822.so, and strigiea_vcf.so all link to libldap-2.4.so.2 but don't call into it, not even to initialize it. Because of this libldap barfs when destroyed, returning a nonzero exit status which bubbles up to kdesu and gets naively lumped into kdesu's "command not found" case. The "command not found" dialog doesn't appear when Login Manager is invoked from the command line because kdesu isn't wrapping it, but the error is still there (as confirmed by running `echo $?` after closing Login Manager).

The bottom line is that either kdepim should be rebuilt without the unnecessary openldap dep, or kdepim upstream should be notified that they're not using openldap as prescribed and it's actually breaking non-kdepim KDE components.
Comment 12 Kevin Kofler 2008-08-04 18:28:23 EDT
Due to some weirdness in the KDE build system, _all_ KDE 4 programs and libraries automatically get linked against OpenLDAP, at least all those using kdepimlibs.
Comment 13 Sterling Winter 2008-08-04 18:38:49 EDT
(In reply to comment #12)
> Due to some weirdness in the KDE build system, _all_ KDE 4 programs and
> libraries automatically get linked against OpenLDAP, at least all those using
> kdepimlibs.

Urgh. So what needs to happen then? Patch kcmshell4 to handle this as a special case so it'll exit cleanly?
Comment 14 Rex Dieter 2008-08-05 11:45:12 EDT
Moving to rawhide (since that's where kdepim4 is)
Comment 15 Konstantin 2008-10-19 21:17:26 EDT
Greetings. Same error here.

After changing KDM theme settings (login manager) in the advanced tab I have this message:

"Command '/usr/bin/kcmshell4 kdm --lang en_US' not found."

Package ver: kdebase-runtime-4.1.2-5.fc10.i386

P.S.: Login manager option at tab 'Theme' - "Get new themes" fails to install themes, 'kcmshell' error appears.
Comment 16 Kevin Kofler 2008-10-26 19:05:02 EDT
*** Bug 468607 has been marked as a duplicate of this bug. ***
Comment 17 Kevin Kofler 2008-11-02 14:30:51 EST
Can you try kdebase-workspace-4.1.2-10 (.fc9 for those on F9, .fc10 for those on Rawhide)? The fix for bug 469235 might resolve this as a side effect.
Comment 18 Colin J Thomson 2008-11-02 15:59:19 EST
Just updated and I am still seeing "Command '/usr/bin/kcmshell4 kdm --lang en_GB' not found." when I close the Login manager config when run from System Settings.
Comment 19 Kevin Kofler 2008-11-02 16:57:47 EST
OK. :-( So we'll keep this open.
We really need to figure out what EXACTLY is going on there, but I'm afraid it probably takes one of us developers/packagers to debug this any further, you already gave all the information you could.
Comment 20 Ngo Than 2008-11-05 05:36:52 EST
it's fixed in kdebase-workspace-4.1.2-11.fc10. Could you please try the new onw from http://koji.fedoraproject.org/koji/buildinfo?buildID=68488

Thanks
Comment 21 Colin J Thomson 2008-11-05 07:30:35 EST
OK, I saw no F9 packages so to save time rebuilding for F9 I installed the F10 packages:

kdebase-workspace-4.1.2-11.fc10.i386
kdebase-workspace-devel-4.1.2-11.fc10.i386
kdebase-workspace-libs-4.1.2-11.fc10.i386
ksysguardd-4.1.2-11.fc10.i386

And I am pleased to report I am not seeing the error anymore.

Note You need to log in before you can comment on or make changes to this bug.