Bug 45765 - NeoMagic 128XD (MM2160) refuses to use software cursor
NeoMagic 128XD (MM2160) refuses to use software cursor
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 04:18 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 13:28:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-25 04:18:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
My laptop, Compaq Presario 1266, uses "NeoMagic 128XD (laptop/notebook) 
MM2160, its hardware cursor has problem (fat sqaure of garbage pixels) and 
I have to modify /etc/X11/XF86Config to use software cursor. This worked 
for all version before RedHat 7.1. The XFree86 comes with RedHat 7.1 
simply refuses to use software cursor even I tried to configure it.
First all, "man neomagic" says I should use
Option "SWCursor" "true"
but the default /etc/X11/XF86Config has a comment line uses
Option "SWcursor" "true"
while the old version of XFree86 used
Option "sw_cursor"
I tried them all, but 
startx &> /tmp/x.out
still clearly prints out X uses:
(II) NEOMAGIC(0): Using H/W Cursor.

I also tried XFree86 4.1.0 version, same problem.

How reproducible:
Always

Steps to Reproduce:
1. modify /etc/X11/XF86Config, section "Device", turn ON "software cursor"
2. start &> /tmp/x.out
3. X window comes up with bad garbage cursor
4. quit X window, check /tmp/x.out, search for "Cursor", it says
"(II) NEOMAGIC(0): Using H/W Cursor"
	

Actual Results:  It happens always on my laptop.

Expected Results:  If I configure /etc/X11/XF86Config to use "Software 
Cursor", it should use. Just like XFree86 came with RedHat 6.0/6.1/7.0

Additional info:
Comment 1 Mike A. Harris 2001-08-28 13:28:51 EDT
I suspect that you are possibly confusing the config files.  XFree86 3.3.6
uses XF86Config, and XFree86 4.x uses XF86Config-4.  Make sure you are
editing the correct file for the server you are using.

Please attach both your X server log, and your config file via the link
below (uncompressed).
Comment 2 Mike A. Harris 2002-02-09 05:21:25 EST
Assuming my suggestion fixed the problem.  If not, please reopen bug
report with requested information attached.

Note You need to log in before you can comment on or make changes to this bug.