Bug 457659 - telepathy-gabble 0.7.7 hits an assertion on connect
telepathy-gabble 0.7.7 hits an assertion on connect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: telepathy-gabble (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-02 20:31 EDT by David Nielsen
Modified: 2008-08-07 13:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 13:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 16963 None None None Never

  None (edit)
Description David Nielsen 2008-08-02 20:31:17 EDT
Description of problem:
Everytime I start empathy on F10 it will start, connect, show part of the buddylist then disconnect. The following can be seen in the terminal.

** (empathy:4262): DEBUG: mission_control_get_presence_actual: MC not running.
** (empathy:4262): DEBUG: mission_control_get_presence_message_actual: MC not running.
** (empathy:4262): DEBUG: mission_control_get_online_connections: MC not running.
** (empathy:4262): DEBUG: mission_control_get_connection_status: MC not running.
** (empathy:4262): DEBUG: mission_control_get_tpconnection: MC not running.


Version-Release number of selected component (if applicable):
empathy-0.23.4-1.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start empathy
  
Actual results:
immidiate disconnection

Expected results:
connected empathy

Additional info:
da_DK.UTF-8
Comment 1 Peter Gordon 2008-08-03 13:46:18 EDT
Does this happen with all accounts, or only specific ones? (If so, which ones?)

I just rebuilt the Rawhide one for my F9 box and it seems to be functioning nicely. What EVRs of the telepathy stack are you using? ("rpm -qa telepathy*" should tell you.)

When did you first notice this issue, and what packages did you update on or about that time? Maybe something in one of its deps somewhere is acting up... :/
Comment 2 David Nielsen 2008-08-03 17:07:28 EDT
I cleanly installed empathy and telepathy (I am only using gabble with gtalk), cleaned the profile and configuration file. Same problem.

telepathy-filesystem-0.0.1-2.fc8.noarch
telepathy-gabble-0.7.7-1.fc10.x86_64
telepathy-salut-0.2.3-2.fc9.x86_64
telepathy-mission-control-4.65-2.fc10.x86_64
telepathy-stream-engine-0.5.3-1.fc10.x86_64
telepathy-glib-0.7.13-1.fc10.x86_64
empathy-0.23.4-1.fc10.x86_64
Comment 3 David Nielsen 2008-08-03 20:58:54 EDT
Just might be related to:
http://bugs.freedesktop.org/show_bug.cgi?id=16963
Comment 4 David Nielsen 2008-08-07 08:24:29 EDT
This is indeed related to telepathy-gabble, reassigning. Upstream bug report linked in #2 now contains a workaround. The reason you can't trigger it on F9 is that the glib2 is Development is more picky about the input it seems. 

Workarounds:
a) Back down to 0.7.6
b) patch 0.7.7 with snippet from upstream
c) wait for 0.7.8

I would favor b or a, keeping jabber working would be advisable, especially since empathy is now part of GNOME.

Note You need to log in before you can comment on or make changes to this bug.