Bug 457679 - foomatic strips special characters from PPD file name
foomatic strips special characters from PPD file name
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 08:20 EDT by Vasile Gaburici
Modified: 2008-09-28 14:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 14:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Troubleshoot text. (28.73 KB, text/plain)
2008-08-03 09:44 EDT, Vasile Gaburici
no flags Details
PPD (18.67 KB, application/octet-stream)
2008-08-03 10:38 EDT, Vasile Gaburici
no flags Details

  None (edit)
Description Vasile Gaburici 2008-08-03 08:20:23 EDT
My non-postscript HP LaserJet 6P started getting fed raw postscript in economy mode (300dpi, draft) after the automated update of cups on Jul 10. The 600dpi non-economy mode still works properly, i.e. postscript gets translated to pcl5 before being fed to it.

I tried deleting an recreating the printer profile, but this had no effect.

Version-Release number of selected component (if applicable):
cups-1.3.7-8.fc9
Comment 1 Tim Waugh 2008-08-03 09:35:49 EDT
Please try running the printing troubleshooter: System->Administration->Printing from the main menu, then Help->Troubleshoot from the menu bar.

It will ask you to print a test page -- do this in the same way as you are currently printing and seeing the incorrect output.

Please attach the resulting troubleshoot.txt file to this bug report.  Thanks.
Comment 2 Vasile Gaburici 2008-08-03 09:44:02 EDT
Created attachment 313292 [details]
Troubleshoot text.

I had already done that. Even the test page comes out as raw postscript (that is a few postscript strings followed by many blank pages) in econo mode. I'm attaching the troubleshoot text.
Comment 3 Tim Waugh 2008-08-03 09:54:51 EDT
Please attach /etc/cups/ppd/HP-LaserJet-6Pecon.ppd.
Comment 4 Vasile Gaburici 2008-08-03 10:38:41 EDT
Created attachment 313293 [details]
PPD

Could the problem be that there are square brackets in the file name?
Comment 5 Tim Waugh 2008-08-04 04:33:03 EDT
Looks like it, yes:

'D [02/Aug/2008:23:35:26 +0300] [Job 16] PPD file: /etc/cups/ppd/HP-LaserJet-6Pecon.ppd',

This is a foomatic bug then.
Comment 6 Vasile Gaburici 2008-08-04 14:55:11 EDT
(In reply to comment #5)
> Looks like it, yes:
> 
> 'D [02/Aug/2008:23:35:26 +0300] [Job 16] PPD file:
> /etc/cups/ppd/HP-LaserJet-6Pecon.ppd',
> 
> This is a foomatic bug then.

Confirmed. I deleted the profile with brackets in the name and created one without brackets; economy mode works now. I changed to priority to low since this is easy to work around.
Comment 7 Tim Waugh 2008-09-05 08:59:27 EDT
Reported upstream:
  http://bugs.linux-foundation.org/show_bug.cgi?id=169
Comment 8 Fedora Update System 2008-09-11 13:04:16 EDT
foomatic-3.0.2-66.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7884
Comment 9 Fedora Update System 2008-09-11 13:09:35 EDT
foomatic-3.0.2-66.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7924
Comment 10 Fedora Update System 2008-09-24 20:00:11 EDT
foomatic-3.0.2-67.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7884
Comment 11 Fedora Update System 2008-09-24 20:22:01 EDT
foomatic-3.0.2-67.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7924
Comment 12 Fedora Update System 2008-09-28 14:41:24 EDT
foomatic-3.0.2-67.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-09-28 14:43:36 EDT
foomatic-3.0.2-67.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.