Bug 457692 - cannot connect to internet with 2.6.27-0.{186,205,208,211}.rc1.git2.fc10.i686 kernels
cannot connect to internet with 2.6.27-0.{186,205,208,211}.rc1.git2.fc10.i686...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 17:06 EDT by Antonio A. Olivares
Modified: 2008-08-06 18:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 18:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio A. Olivares 2008-08-03 17:06:35 EDT
Description of problem:
Cannot connect to internet using MyCricket Wireless USB Broadband Modem.  

http://www.mycricket.com/broadband/

I have not succeeded connecting with 2.6.27 rc kernels 


Version-Release number of selected component (if applicable):
kernel-2.6.27-0.205.rc1.git2.fc10.i686
but also 208, and 211 from koji fail as well :(


How reproducible:
Boot into Fedora rawhide with any of these 2.6.27-0.{186,205,208,211}.rc1.git2.fc10.i686 kernels.  pppd bombs out with error 1


Steps to Reproduce:
1.  Login in as regular user
2.  become su -, and enter password
3.  type wvdial and you can see the results 
  
Actual results:

[root@localhost ~]# wvdial                                                  
--> WvDial: Internet dialer version 1.60                                    
--> Cannot get information for serial port.                                 
--> Initializing modem.                                                     
--> Sending: ATZ                                                            
ATZ                                                                         
OK                                                                          
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                              
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                                           
OK                                                                          
--> Modem initialized.                                                      
--> Sending: ATDT#777                                                       
--> Waiting for carrier.                                                    
ATDT#777                                                                    
CONNECT                                                                     
--> Carrier detected.  Starting PPP immediately.                            
--> Starting pppd at Fri Aug  1 13:25:56 2008                               
--> Pid of pppd: 3390                                                       
--> pppd: 0[1d]y �&y                                                        
--> Disconnecting at Fri Aug  1 13:25:57 2008                               
--> The PPP daemon has died: Fatal pppd error (exit code = 1)               
--> man pppd explains pppd error codes in more detail.                      
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.                                                   
--> Auto Reconnect will be attempted in 5 seconds                           
--> Cannot get information for serial port.                                 
--> Initializing modem.                                                     
--> Sending: ATZ                                                            
ATZ                                                                         
OK                                                                          
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                              
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                                           
OK                                                                          
--> Modem initialized.                                                      
--> Cannot get information for serial port.                                 
--> Initializing modem.                                                     
--> Sending: ATZ                                                            
ATZ                                                                         
OK                                                                          
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                              
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                                           
OK                                                                          
--> Modem initialized.                                                      
--> Sending: ATDT#777                                                       
--> Waiting for carrier.                                                    
ATDT#777                                                                    
CONNECT                                                                     
--> Carrier detected.  Starting PPP immediately.                            
--> Starting pppd at Fri Aug  1 13:26:05 2008                               
--> Pid of pppd: 3408                                                       
--> pppd: 0[1d]y �&y                                                        
--> Disconnecting at Fri Aug  1 13:26:05 2008                               
--> The PPP daemon has died: Fatal pppd error (exit code = 1)               
--> man pppd explains pppd error codes in more detail.                      
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.                                                   
--> Auto Reconnect will be attempted in 10 seconds                          
--> Cannot get information for serial port.                                 
--> Initializing modem.                                                     
--> Sending: ATZ                                                            
ATZ                                                                         
OK                                                                          
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                              
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                                           
OK                                                                          
--> Modem initialized.                                                      
--> Cannot get information for serial port.                                 
--> Initializing modem.                                                     
--> Sending: ATZ                                                            
ATZ                                                                         
OK                                                                          
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                              
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0                                           
OK                                                                          
--> Modem initialized.                                                      
--> Sending: ATDT#777                                                       
--> Waiting for carrier.                                                    
ATDT#777                                                                    
CONNECT                                                                     
--> Carrier detected.  Starting PPP immediately.                            
--> Starting pppd at Fri Aug  1 13:26:18 2008                               
--> Pid of pppd: 3474                                                       
--> pppd: 0[1d]y �&y                                                        
--> Disconnecting at Fri Aug  1 13:26:18 2008                               
--> The PPP daemon has died: Fatal pppd error (exit code = 1)               
--> man pppd explains pppd error codes in more detail.                      
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.                                                   
--> Auto Reconnect will be attempted in 20 seconds                          
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
^CCaught signal 2:  Attempting to exit gracefully...
--> Disconnecting at Fri Aug  1 13:26:43 2008
[root@localhost ~]#

Error 1 from man pppd is as follows:
EXIT STATUS
       The exit status of pppd is set to indicate whether any  error
       was  detected,  or  the reason for the link being terminated.
       The values used are:

       0      Pppd has detached, or  otherwise  the  connection  was
              successfully  established and terminated at the peer’s
              request.

       1      An immediately fatal error of some kind occurred, such
              as an essential system call failing, or running out of
              virtual memory.

       2      An error was detected in processing the options given,
              such as two mutually exclusive options being used.

       3      Pppd  is  not setuid-root and the invoking user is not
              root.

       4      The kernel does not support PPP, for example, the  PPP
              kernel driver is not included or cannot be loaded.
<snip removed >

<part of dmesg follows> 

ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x1800, format=0x4011                                                                     
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
r8169: eth1: link down                                                      
ADDRCONF(NETDEV_UP): eth1: link is not ready                                
[drm] Initialized drm 1.1.0 20060810                                        
pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16                
pci 0000:00:02.0: setting latency timer to 64                               
[drm] Initialized i915 1.6.0 20060119 on minor 0                            
SELinux:  Context system_u:object_r:user_gconf_home_t:s0 is not valid (left unmapped).                                                                  
SELinux:  Context unconfined_u:object_r:user_gconf_home_t:s0 is not valid (left unmapped).                                                              
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x4011                                                                    
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x4011                                                                    
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x4011                                                                    
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x9, stream=0x1, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x4011                                                                    
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x9, stream=0x1, channel=0, format=0x4011                                               
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x9       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x9       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
SELinux:  Context system_u:object_r:user_gnome_home_t:s0 is not valid (left unmapped).                                                                  
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x9       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x31                                                                      
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x31                                                                      
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_intel.c:1394: azx_pcm_prepare: bufsize=0x10000, format=0x31                                                                      
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x3, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x31                                                 
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4       
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5       
uhci_hcd 0000:00:1d.2: reserve dev 2 ep81-INT, period 32, phase 16, 23 us   
PPP generic driver version 2.4.2                                            
uhci_hcd 0000:00:1d.2: release dev 2 ep81-INT, period 32, phase 16, 23 us
uhci_hcd 0000:00:1d.2: reserve dev 2 ep81-INT, period 32, phase 16, 23 us
uhci_hcd 0000:00:1d.2: release dev 2 ep81-INT, period 32, phase 16, 23 us
uhci_hcd 0000:00:1d.2: reserve dev 2 ep81-INT, period 32, phase 16, 23 us
uhci_hcd 0000:00:1d.2: release dev 2 ep81-INT, period 32, phase 16, 23 us
uhci_hcd 0000:00:1d.2: reserve dev 2 ep81-INT, period 32, phase 16, 23 us
[olivares@localhost ~]$ su -
Password:
[root@localhost ~]# tail -f /var/log/messages
Aug  1 13:25:57 localhost kernel: PPP generic driver version 2.4.2
Aug  1 13:25:57 localhost pppd[3390]: pppd 2.4.4 started by root, uid 0
Aug  1 13:25:57 localhost pppd[3390]: Couldn't set tty to PPP discipline: Invalid argument
Aug  1 13:25:57 localhost pppd[3390]: Exit.
Aug  1 13:26:05 localhost pppd[3408]: pppd 2.4.4 started by root, uid 0
Aug  1 13:26:05 localhost pppd[3408]: Couldn't set tty to PPP discipline: Invalid argument
Aug  1 13:26:05 localhost pppd[3408]: Exit.
Aug  1 13:26:18 localhost pppd[3474]: pppd 2.4.4 started by root, uid 0
Aug  1 13:26:18 localhost pppd[3474]: Couldn't set tty to PPP discipline: Invalid argument
Aug  1 13:26:18 localhost pppd[3474]: Exit.
^C

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.27-0.205.rc1.git2.fc10.i686 #1 SMP Thu Jul 31 16:12:27 EDT 2008 i686 i686 i386 GNU/Linux

from man pppd error 1 is the following: 

      1      An immediately fatal error of some kind occurred, such
              as an essential system call failing, or running out of
              virtual memory.

[root@localhost ~]# dmesg | grep 'usb'                                      
usbcore: registered new interface driver usbfs                              
usbcore: registered new interface driver hub                                
usbcore: registered new device driver usb                                   
usbcore: registered new interface driver hiddev                             
usbcore: registered new interface driver usbhid                             
usbhid: v2.6:USB HID core driver                                            
drivers/usb/core/inode.c: creating file 'devices'                           
drivers/usb/core/inode.c: creating file '001'                               
usb usb1: default language 0x0409                                           
usb usb1: uevent                                                            
usb usb1: usb_probe_device                                                  
usb usb1: configuration #1 chosen from 1 choice                             
usb usb1: adding 1-0:1.0 (config #1, interface 0)                           
usb 1-0:1.0: uevent                                                         
hub 1-0:1.0: usb_probe_interface                                            
hub 1-0:1.0: usb_probe_interface - got id                                   
hub 1-0:1.0: no power switching (usb 1.0)                                   
drivers/usb/core/inode.c: creating file '001'                               
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002               
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1          
usb usb1: Product: EHCI Host Controller                                     
usb usb1: Manufacturer: Linux 2.6.27-0.205.rc1.git2.fc10.i686 ehci_hcd      
usb usb1: SerialNumber: 0000:00:1d.7                                        
drivers/usb/core/inode.c: creating file '002'                               
usb usb2: default language 0x0409                                           
usb usb2: uevent                                                            
usb usb2: usb_probe_device                                                  
usb usb2: configuration #1 chosen from 1 choice                             
usb usb2: adding 2-0:1.0 (config #1, interface 0)                           
usb 2-0:1.0: uevent                                                         
hub 2-0:1.0: usb_probe_interface                                            
hub 2-0:1.0: usb_probe_interface - got id                                   
hub 2-0:1.0: no power switching (usb 1.0)                                   
drivers/usb/core/inode.c: creating file '001'                               
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001               
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1          
usb usb2: Product: UHCI Host Controller                                     
usb usb2: Manufacturer: Linux 2.6.27-0.205.rc1.git2.fc10.i686 uhci_hcd      
usb usb2: SerialNumber: 0000:00:1d.0                                        
drivers/usb/core/inode.c: creating file '003'                               
usb usb3: default language 0x0409                                           
usb usb3: uevent                                                            
usb usb3: usb_probe_device                                                  
usb usb3: configuration #1 chosen from 1 choice                             
usb usb3: adding 3-0:1.0 (config #1, interface 0)                           
usb 3-0:1.0: uevent                                                         
hub 3-0:1.0: usb_probe_interface                                            
hub 3-0:1.0: usb_probe_interface - got id                                   
hub 3-0:1.0: no power switching (usb 1.0)                                   
drivers/usb/core/inode.c: creating file '001'                               
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001               
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1          
usb usb3: Product: UHCI Host Controller                                     
usb usb3: Manufacturer: Linux 2.6.27-0.205.rc1.git2.fc10.i686 uhci_hcd      
usb usb3: SerialNumber: 0000:00:1d.1                                        
drivers/usb/core/inode.c: creating file '004'                               
usb usb4: default language 0x0409                                           
usb usb4: uevent                                                            
usb usb4: usb_probe_device                                                  
usb usb4: configuration #1 chosen from 1 choice                             
usb usb4: adding 4-0:1.0 (config #1, interface 0)                           
usb 4-0:1.0: uevent                                                         
hub 4-0:1.0: usb_probe_interface                                            
hub 4-0:1.0: usb_probe_interface - got id                                   
hub 4-0:1.0: no power switching (usb 1.0)                                   
drivers/usb/core/inode.c: creating file '001'                               
usb usb4: New USB device found, idVendor=1d6b, idProduct=0001               
usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1          
usb usb4: Product: UHCI Host Controller                                     
usb usb4: Manufacturer: Linux 2.6.27-0.205.rc1.git2.fc10.i686 uhci_hcd      
usb usb4: SerialNumber: 0000:00:1d.2                                        
drivers/usb/core/inode.c: creating file '005'                               
usb usb5: default language 0x0409                                           
usb usb5: uevent                                                            
usb usb5: usb_probe_device                                                  
usb usb5: configuration #1 chosen from 1 choice                             
usb usb5: adding 5-0:1.0 (config #1, interface 0)                           
usb 5-0:1.0: uevent                                                         
hub 5-0:1.0: usb_probe_interface                                            
hub 5-0:1.0: usb_probe_interface - got id                                   
hub 5-0:1.0: no power switching (usb 1.0)                                   
usb 4-1: new full speed USB device using uhci_hcd and address 2             
drivers/usb/core/inode.c: creating file '001'                               
usb usb5: New USB device found, idVendor=1d6b, idProduct=0001               
usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1          
usb usb5: Product: UHCI Host Controller                                     
usb usb5: Manufacturer: Linux 2.6.27-0.205.rc1.git2.fc10.i686 uhci_hcd      
usb usb5: SerialNumber: 0000:00:1d.3                                        
usb 4-1: skipped 4 descriptors after interface                              
usb 4-1: default language 0x0409                                            
usb 4-1: uevent                                                             
usb 4-1: usb_probe_device                                                   
usb 4-1: configuration #1 chosen from 1 choice                              
usb 4-1: adding 4-1:1.0 (config #1, interface 0)                            
usb 4-1:1.0: uevent                                                         
usb 4-1: adding 4-1:1.1 (config #1, interface 1)                            
usb 4-1:1.1: uevent                                                         
usb 4-1: adding 4-1:1.2 (config #1, interface 2)                            
usb 4-1:1.2: uevent                                                         
drivers/usb/core/inode.c: creating file '002'                               
usb 4-1: New USB device found, idVendor=0d08, idProduct=0300                
usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0           
usb 4-1: Product: UTStarcom UM100                                           
usb 4-1: Manufacturer: UTStarcom, Incorporated                              
usb usb2: suspend_rh (auto-stop)                                            
usb usb3: suspend_rh (auto-stop)                                            
usb usb5: suspend_rh (auto-stop)                                            
usb usb1: bus auto-suspend                                                  
usb usb2: bus auto-suspend                                                  
usb usb2: suspend_rh                                                        
usb usb3: bus auto-suspend                                                  
usb usb3: suspend_rh                                                        
usb usb5: bus auto-suspend                                                  
usb usb5: suspend_rh                                                        
SELinux: initialized (dev usbfs, type usbfs), uses genfs_contexts           
usb usb2: uevent                                                            
usb 2-0:1.0: uevent                                                         
usb usb3: uevent                                                            
usb 3-0:1.0: uevent                                                         
usb usb4: uevent                                                            
usb 4-0:1.0: uevent                                                         
usb 4-1: uevent                                                             
usb 4-1:1.0: uevent                                                         
usb 4-1:1.1: uevent                                                         
usb 4-1:1.2: uevent                                                         
usb usb5: uevent                                                            
usb 5-0:1.0: uevent                                                         
usb usb1: uevent                                                            
usb 1-0:1.0: uevent                                                         
cdc_acm 4-1:1.0: usb_probe_interface                                        
cdc_acm 4-1:1.0: usb_probe_interface - got id
usbcore: registered new interface driver cdc_acm

Expected results:

I have a working connection with 2.6.26rc kernel 
Last Fedora rawhide kernel that works is here:
 
[olivares@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.26-0.44.rc4.git2.fc10.i686 #1 SMP Thu May 29 13:44:38 EDT 2008 i686 i686 i386 GNU/Linux

working wvdial.conf here(except password and username):

[olivares@localhost ~]$ cat /etc/wvdial.conf

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Phone = #777
ISDN = 0
Username = MYUSERNAME
Init1 = ATZ
Password = MYPASSWORD.
Modem = /dev/ttyACM0
Baud = 460800
Carrier Check = no
Stupid Mode = yes

[olivares@localhost ~]$ su -                    
Password:                                       
[root@localhost ~]# wvdial                      
--> WvDial: Internet dialer version 1.60        
--> Cannot get information for serial port.     
--> Initializing modem.                         
--> Sending: ATZ                                
ATZ                                             
OK                                              
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0  
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0               
OK                                              
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Aug  2 22:41:46 2008
--> Pid of pppd: 3307
--> Using interface ppp0
--> pppd: 0��[08]���[08]
--> pppd: 0��[08]���[08]
--> pppd: 0��[08]���[08]
--> pppd: 0��[08]���[08]
--> local  IP address 10.6.208.86
--> pppd: 0��[08]���[08]
--> remote IP address 172.28.220.130
--> pppd: 0��[08]���[08]
--> primary   DNS address 172.28.221.53
--> pppd: 0��[08]���[08]
--> secondary DNS address 172.28.221.54
--> pppd: 0��[08]���[08]

[root@localhost ~]# tail -f /var/log/messages
Aug  2 22:40:23 localhost kernel: ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x5, stream=0x5, channel=0, format=0x4011                     
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2                                                         
Aug  2 22:40:25 localhost pulseaudio[2887]: pcm_hw.c: SNDRV_PCM_IOCTL_DRAIN failed                                                                              
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3                                                         
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4                                                         
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x2
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x3
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x4
Aug  2 22:40:25 localhost kernel: ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x5
Aug  2 22:41:47 localhost kernel: PPP generic driver version 2.4.2
Aug  2 22:41:47 localhost pppd[3307]: pppd 2.4.4 started by root, uid 0
Aug  2 22:41:47 localhost pppd[3307]: Using interface ppp0
Aug  2 22:41:47 localhost pppd[3307]: Connect: ppp0 <--> /dev/ttyACM0
Aug  2 22:41:55 localhost pppd[3307]: CHAP authentication succeeded
Aug  2 22:41:55 localhost pppd[3307]: CHAP authentication succeeded
Aug  2 22:41:55 localhost kernel: PPP Deflate Compression module registered
Aug  2 22:41:57 localhost pppd[3307]: local  IP address 10.6.208.86
Aug  2 22:41:57 localhost pppd[3307]: remote IP address 172.28.220.130
Aug  2 22:41:57 localhost pppd[3307]: primary   DNS address 172.28.221.53
Aug  2 22:41:57 localhost pppd[3307]: secondary DNS address 172.28.221.54


Additional info:
Upon request.  Thank you for looking into this!
Comment 1 Dave Jones 2008-08-03 17:29:41 EDT
Possibly related to the recent tty changes.  Alan?
Comment 2 Alan Cox 2008-08-04 07:05:03 EDT
Probably the ldisc load bug, if so its already fixed in the latest git tree
Comment 3 Antonio A. Olivares 2008-08-06 16:47:21 EDT
Dear all,


kernel 226 from rawhide updates fixes X issues and I can connect to net :)

[olivares@localhost ~]$ uname -r
2.6.27-0.226.rc1.git5.fc10.i686 
[olivares@localhost ~]$ su -    
Password:                       
[root@localhost ~]# wvdial      
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.                    
--> Sending: ATZ                           
ATZ                                        
OK                                         
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0             
OK                                            
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Wed Aug  6 15:37:42 2008
--> Pid of pppd: 3477
--> Using interface ppp0
--> pppd: 0[1d], �&,
--> pppd: 0[1d], �&,
--> pppd: 0[1d], �&,
--> pppd: 0[1d], �&,
--> local  IP address 10.6.182.193
--> pppd: 0[1d], �&,
--> remote IP address 172.28.220.130
--> pppd: 0[1d], �&,
--> primary   DNS address 172.28.221.53
--> pppd: 0[1d], �&,
--> secondary DNS address 172.28.221.54
--> pppd: 0[1d], �&,


[root@localhost ~]# tail -f /var/log/messages
Aug  6 15:37:42 localhost pppd[3477]: pppd 2.4.4 started by root, uid 0
Aug  6 15:37:42 localhost pppd[3477]: Using interface ppp0
Aug  6 15:37:42 localhost pppd[3477]: Connect: ppp0 <--> /dev/ttyACM0
Aug  6 15:37:45 localhost pppd[3477]: CHAP authentication succeeded
Aug  6 15:37:45 localhost pppd[3477]: CHAP authentication succeeded
Aug  6 15:37:45 localhost kernel: PPP Deflate Compression module registered
Aug  6 15:37:46 localhost pppd[3477]: local  IP address 10.6.182.193
Aug  6 15:37:46 localhost pppd[3477]: remote IP address 172.28.220.130
Aug  6 15:37:46 localhost pppd[3477]: primary   DNS address 172.28.221.53
Aug  6 15:37:46 localhost pppd[3477]: secondary DNS address 172.28.221.54


Should you need further information let me know.  As of right now the problems that I encountered with the previous rawhide kernels have been cured with this new 0226 kernel :) 

Best Regards,

Antonio
Comment 4 Alan Cox 2008-08-06 18:30:28 EDT
Thanks for the report, glad to know it was the fixed bug.

Note You need to log in before you can comment on or make changes to this bug.