Bug 457724 - URL in the location bar doesn't change while viewing different links, Selenium could not find right element link
URL in the location bar doesn't change while viewing different links, Seleniu...
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Mo Morsi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 05:25 EDT by Xiaohong Wang
Modified: 2010-03-16 13:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 13:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaohong Wang 2008-08-04 05:25:52 EDT
Description of problem:
Go through different links in the oVirt Administration User Interface, the URL in the location bar doesn't change.
Selenium couldn't catch the element link.

Version-Release number of selected component (if applicable):
oVirt 0.91-1

How reproducible:


Steps to Reproduce:
1. Install the oVirt Developer Version
2. Log in the oVirt Administration User Interface. 
3. Use Selenium to record test steps
4. Click the links in the oVirt Administration User Interface
  
Actual results:
The URL in the location bar always keep in the same (e.g. http://management.priv.ovirt.org/ovirt/ or any other like http://management.priv.ovirt.org/ovirt/hardware/show_vms/1) instead of each link's correct URL, if you move mouse to those link you could see their URL are different.
Use Selenium to play the recorded test case, it stops at switch to different links for error found:
[error] Element link not found 

Expected results:


Additional info:
Comment 1 Lawrence Lim 2008-08-04 09:55:54 EDT
xwang,
I think adding a screenshot will help us understand the bug easier, ie, where the URL remain the same.
Comment 2 Hugh Brock 2008-10-17 16:24:57 EDT
I believe we came up with a Selenium workaround for this, didn't we? Mo, I've assigned this to you, but if the problem is fixed please close it... thanks...
Comment 3 Mo Morsi 2008-10-27 13:10:53 EDT
While it can use it, Selenium doesn't need the location bar to do its work. Rather the way our current interface tests function is, the site is brought up by going to http://192.168.50.2/ovirt, then various elements on the page are clicked, and finally the 'wait_for_condition' method, that the selenium api provides, is used to verify elements on the page, not the contents of the location bar. So for example if we used selenium to click on a hardware pool, we'd verify the title of the pool appears where it should on the page, the tabs are available for the user to edit the pool, etc

Since you can go directly to the page you are looking for by opening that url manually via the location bar or selenium, eg http://192.168.50.2/ovirt/hardware/show_vms/1, you can bypass navigating to the desired page in a selenium test, and just open the page / perform the steps required to test its functionality. Furthermore the direct urls allow the site to be bookmarkable without needing the javascript which dynamically load the content of the site without page refreshes to have to also update the location bar (which I'm not sure is possible without loading new content into the page).

If a test is failing it is most likely due to recent changes in the interface, such as to the nav tree, not related to the location bar, which will need to be pinpointed / identified separately in any case.

Note You need to log in before you can comment on or make changes to this bug.