Bug 457735 - Tomboy crashes while doing execheap over VNC X session
Tomboy crashes while doing execheap over VNC X session
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 07:58 EDT by Paul W. Frields
Modified: 2009-07-14 13:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:18:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace and log of Tomboy crash via VNC X session (4.91 KB, text/plain)
2008-08-04 07:58 EDT, Paul W. Frields
no flags Details

  None (edit)
Description Paul W. Frields 2008-08-04 07:58:04 EDT
Created attachment 313354 [details]
Stack trace and log of Tomboy crash via VNC X session

tomboy-0.10.1-2.fc9.x86_64

The application works fine if I log into X on the console.  However, in my home office I usually work off another station for ergonomic reasons.  I launch a VNC X server on the remote system and then full-screen it where I'm sitting.  Tomboy won't start under these circumstances.  I believe this behavior is fairly new, since I recall it working during the week of July 21st.  (I use it constantly for work tracking.)

The problem appears to be related to SELinux denying access to heap memory.  The explanation from setroubleshoot says this is a security flaw, and Tomboy shouldn't be doing this.

'''
host=victoria type=AVC msg=audit(1217850821.390:90): avc: denied { execheap } for pid=7573 comm="tomboy" scontext=unconfined_u:unconfined_r:unconfined_notrans_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_notrans_t:s0-s0:c0.c1023 tclass=process

host=victoria type=SYSCALL msg=audit(1217850821.390:90): arch=c000003e syscall=10 success=no exit=-13 a0=297a000 a1=1000 a2=7 a3=312ef67a70 items=0 ppid=7199 pid=7573 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts1 ses=1 comm="tomboy" exe="/usr/bin/mono" subj=unconfined_u:unconfined_r:unconfined_notrans_t:s0-s0:c0.c1023 key=(null) 
'''

I'll post a stack trace since I also installed the debuginfo package stack for Tomboy.
Comment 1 Hendrik Borghorst 2008-08-04 21:35:19 EDT
Hello,

could you please tell how you launch the VNC Xserver so I can check if it is reproduceable. Have you tried running it after running "setenforce 0" as root?
Comment 2 Paul W. Frields 2008-08-05 08:06:12 EDT
(In reply to comment #1)
> could you please tell how you launch the VNC Xserver so I can check if it is
> reproduceable. Have you tried running it after running "setenforce 0" as root?

Two hosts, "laptop" where the vncserver runs, and "desktop" where I am working.

From "desktop," run:
$ ssh laptop vncserver -geometry 1680x1050

Then from "desktop," run:
$ vncviewer laptop:1

Setting SELinux to permissive takes care of the problem, as does the more granular "setsebool -P allow_execheap=1".

This is under selinux-policy-targeted-3.3.1-79.fc9.noarch.
Comment 3 Paul W. Frields 2008-09-22 08:40:39 EDT
Ping?  Problem continues to be irksome....
Comment 4 Bug Zapper 2009-06-09 22:22:18 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-07-14 13:18:48 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.