Bug 457756 - RFE: add Home to top level Menu (like kde3)
RFE: add Home to top level Menu (like kde3)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 09:50 EDT by Juha Tuomala
Modified: 2015-07-13 13:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: kdebase-4.2.0-6.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 05:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-08-04 09:50:19 EDT
Description of problem:
There has been and should be a menu entry that would open the 
user's own home dir with dolphin. 

Version-Release number of selected component (if applicable):
kdebase-workspace-4.1.0-3.fc9.x86_64

How reproducible:
always.

Additional info:
installed from f9 updates-testing.
Comment 1 Rex Dieter 2008-08-04 09:57:25 EDT
View->Panels->Places

For me, shows "Home", "Network", "Trash"... among other things.
Comment 2 Rex Dieter 2008-08-04 09:58:27 EDT
Or even:  Go -> Home
Comment 3 Kevin Kofler 2008-08-04 10:08:16 EDT
But that's from within Dolphin, it's not a shortcut at the top level of the K menu (Kickoff in classic mode).

As far as I can tell from kde4-applications.menu, to add such a shortcut, there has to be a .desktop file with the categories KDE;Core;.
Comment 4 Rex Dieter 2008-08-04 10:16:40 EDT
I understand now, yes, a difference from KDE3, but not all that sure whether to emulate kde3 behavior here exactly is necessarily a good choice.
Comment 5 Kevin Kofler 2008-08-04 10:26:37 EDT
Assuming we want to add this at all, is kdebase-workspace the right place to add this or kdebase? Dolphin is in kdebase, so if Dolphin is to install such a .desktop file, kdebase would be the logical place.
Comment 6 Rex Dieter 2008-08-04 10:29:05 EDT
yes, kdebase, of course.
Comment 7 Juha Tuomala 2008-08-04 12:21:04 EDT
> but not all that sure whether to
> emulate kde3 behavior here exactly is necessarily a good choice.

Well, $HOME is something accessed so frequently that it should
be in top level. Same applies to systemsettings and help too.

I would assume that powerusers have their shortcuts elsewhere and
also use alt+F2 - but who really suffer about this are the ones
who don't know how to do those.
Comment 8 Juha Tuomala 2008-08-04 12:22:50 EDT
And yes, this is *classic* menu. IMO thinks that the new menu thingy should have never been put to default anyway. May be shiny and colorful but has nothing to do with usability.
Comment 9 Steven M. Parrish 2008-08-05 08:46:42 EDT
Sounds like this is more of a feature request than a bug.  Going to assign it for now and see what the SiG wants to do with it.
Comment 10 Rex Dieter 2008-08-05 08:58:52 EDT
And it's not specific to Classic menu either.  When/if we do this change, it'll affect both kickoff and classic.
Comment 11 Steven M. Parrish 2008-09-25 19:15:08 EDT
I know we discussed this during a SiG meeting.  Any plans to implement it for F9 or are we just waiting for Rawhide?
Comment 12 Steven M. Parrish 2009-02-06 10:55:00 EST
Been awhile since this was discussed.  Do we want to leave this open for future consideration or close it?
Comment 13 Lukáš Tinkl 2009-02-10 12:05:09 EST
BTW, this is only about the classic menu, the Kickoff menu contains 'My Computer -> Home' entry
Comment 14 Lukáš Tinkl 2009-02-19 05:59:05 EST
Fixed in kdebase-4.2.0-6.fc10

Note You need to log in before you can comment on or make changes to this bug.