This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457758 - /sbin/mkdumprd parses comment lines of /etc/mdadm.conf
/sbin/mkdumprd parses comment lines of /etc/mdadm.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 10:10 EDT by Charlotte Richardson
Modified: 2009-09-09 01:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 600605 (view as bug list)
Environment:
Last Closed: 2009-01-20 15:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct parsing of mdadm.conf (1.04 KB, patch)
2008-08-04 13:50 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Charlotte Richardson 2008-08-04 10:10:44 EDT
Description of problem:
/sbin/mkdumprd confuses itself by parsing comment lines in /etc/mdadm.conf. A user had "level=0" instead of "level=radi0" in a commented-out line of /etc/mdadm.conf (he had been trying to set up a raid0 array). Then he made a change to /etc/kdump.conf to add a needed kdump_pre script. Then he tried to do service kdump restart. /etc/mkdumprd got:

Rebuilding /boot/initrd-2.6.18-92.el5kdump.img
No module 0 found for kernel 2.6.18-92.el5, aborting.
Failed to run mkdumprd
Starting kdump: [FAILED]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add a commented-out line to /etc/mdadm containg "level=0".
2. Edit /etc/kdump.conf.
3. service kdump restart
  
Actual results:
You get the error shown above. Then you spend a long time trying to figure out what module "0" is... Then you eventually find the comment line in /etc/mdadm.conf and delete it.

Expected results:
/sbin/mkdumprd should ignore comment lines.

Additional info:
Comment 1 Neil Horman 2008-08-04 13:50:26 EDT
Created attachment 313385 [details]
patch to correct parsing of mdadm.conf

Please try this patch and confirm that it fixes the problem.  Thanks!
Comment 2 Charlotte Richardson 2008-08-04 14:17:05 EDT
Looks like the patch works. The original user has already reinstalled his system; I hacked up the mdadm.conf on my system to have a comment line of the problematical sort and then edited /etc/kdump.conf and did service kdump restart. It now successfully ignores the comment.  Thanks!
Comment 3 RHEL Product and Program Management 2008-08-04 14:52:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Neil Horman 2008-08-04 15:48:25 EDT
Fixed in -30.el5.  Thanks!
Comment 8 errata-xmlrpc 2009-01-20 15:59:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0105.html

Note You need to log in before you can comment on or make changes to this bug.