Bug 457782 - F9 Auto-Raise goes berserk
F9 Auto-Raise goes berserk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
10
All Linux
urgent Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 12:13 EDT by Robert Peterson
Modified: 2014-06-18 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 15:54:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Peterson 2008-08-04 12:13:34 EDT
Description of problem:
When I'm using auto-raise in gnome, it periodically goes berserk,
blinking all visible windows exactly ten times, then none of the
windows will raise ever again.  The only way to recover is to restart
X with ctrl-alt-backspace.

Version-Release number of selected component (if applicable):
F9

How reproducible:
Frequently--every hour or less if I'm trying

Steps to Reproduce:
1. Open a bunch of windows: mostly gnome-terminals and xemacs sessions
2. Turn on auto-raise (system->preferences->look and feel->windows,
   check "Select windows when the mouse moves over them" and
   check "Raise selected windows after an interval".
   I was using 0.2 seconds when this occurred last.)
3. Move your mouse over the windows to raise them.
4. Try moving your mouse over a second window before the first window
   has been raised properly.
  
Actual results:
All visible windows blink ten times, then all stop blinking and nothing
you can do will raise them ever again (clicking or mouse-over).
Clicking and/or moving your mouse has no affect to stop the ten-blink
gnome time-bomb.

Expected results:
Auto-raise should raise the windows properly.

Additional info:
This did NOT happen in F8 because I've used F8 in exactly the same
way for several months without an issue.  With F9, this problem
occurs to me roughly every hour or so.
Comment 1 Robert Peterson 2008-08-04 14:40:34 EDT
Since I've gotten this four times today, I'm experimenting a bit.
I managed to recreate the problem without auto-raise.  So it is
apparently just a matter of switching focus.
Comment 2 Robert Peterson 2008-08-04 15:46:34 EDT
More information: When it's failing, two of the desktops keep
alternately changing focus.  For example, desktop 1 will focus and
turn blue on the workplace switcher bar while desktop 2 is white,
then one second later, desktop 2 will focus and turn blue on the
workplace switcher, while 1 is white.  It alternates between 1 and 2
ten times, and then all the windows lose their blue title bar and
the cursor becomes a vertical bar and I can't select any windows.
No clicks (left, right, middle) have any effect.  Some of the screens
keep painting (for example, a script running on an xterm still produces
output).  The keyboard doesn't seem to select anything either, so
doing alt-escape has no effect.  System responds to ctrl-alt-backspace
to restart gnome though.
Comment 3 Ray Strode [halfline] 2008-08-04 16:55:05 EDT
reassigning to metacity, it's apparently crashing.
Comment 4 Bug Zapper 2008-11-25 21:39:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Robert Peterson 2008-12-17 22:20:28 EST
This problem does not seem to be in F10.  F9 was completely unusable
with my configuration and usage.  I've been using F10 since it became
available and haven't seen the problem there.  Feel free to close as
CURRENTRELEASE if you want.
Comment 6 Owen Taylor 2009-11-16 15:54:33 EST
Closing as suggested

Note You need to log in before you can comment on or make changes to this bug.