Bug 457783 - mime-type/extension binding for .rpm is wrong
mime-type/extension binding for .rpm is wrong
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 12:14 EDT by Juha Tuomala
Modified: 2009-02-19 06:42 EST (History)
6 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-08-04 12:14:11 EDT
Description of problem:
Clicking a page with rpm packages sends rpm mime type

application/x-rpm

over http. Currently f9 suggests 'Archive Manager' to 
handle that file format which is wrong.

Version-Release number of selected component (if applicable):
kde-settings-4.0-25.fc9.noarch

How reproducible:
always before you change your personal preferences.

Expected results:
launch the default fedora pkg tool, whatever that in this 
release happens to be...sigh.
Comment 1 Steven M. Parrish 2008-09-25 19:11:55 EDT
Any movement on this issue?
Comment 2 Kevin Kofler 2008-09-25 23:44:48 EDT
KDE 4 uses the shared-mime-info data. This is probably an issue in either shared-mime-info or gnome-packagekit.
Comment 3 Bastien Nocera 2008-09-27 08:17:12 EDT
$ grep application/x-rpm /usr/share/applications/*
/usr/share/applications/defaults.list:application/x-rpm=gpk-install-file.desktop

PackageKit is already the GNOME default for RPM files. Get KDE to use the defaults.list file, or change whatever they use to select the default applications. Not a shared-mime-info or PackageKit problem.
Comment 4 Rex Dieter 2008-09-27 08:32:14 EDT
kde uses it's own (mostly empty atm) defaults.list, reassigning -> kde-settings
Comment 5 Steven M. Parrish 2009-02-06 10:41:31 EST
Ping?
Comment 6 Rex Dieter 2009-02-06 10:57:05 EST
Ick, looks like defaults.list hacking doesn't work on kde4 (seems we need to add a mimeapps.list)

Another parallel approach would be to add (something like):
InitialPreference=5
to kpackagekit.desktop

And alternatively removing x-rpm mimetype from ark.desktop
Comment 7 Rex Dieter 2009-02-06 11:29:41 EST
OK, 
kpackagekit-0.4.2-0.2.20090128svn.fc11 built with InitialPreference
and added mimeapps.list to kde-settings upstream svn.

I'll let these simmer a bit, and then backport these mods to F-9/F-10 too, adding as kde42 blocker.
Comment 8 Kevin Kofler 2009-02-09 13:34:55 EST
This is fixed in the iteration of the KDE 4.2 testing updates which hit testing the day before yesterday, tracking as such and removing from blocker.

Note You need to log in before you can comment on or make changes to this bug.