This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457795 - streamtuner immediately SIGSEGVs on startup
streamtuner immediately SIGSEGVs on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: streamtuner (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Haase
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 13:17 EDT by Tom London
Modified: 2008-11-09 19:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-09 19:13:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-08-04 13:17:14 EDT
Description of problem:
Get an immediate crash of streamtuner on startup on my Rawhide system.

[tbl@localhost ~]$ gdb streamtuner
GNU gdb Fedora (6.8-19.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(gdb) run
Starting program: /usr/bin/streamtuner 
[Thread debugging using libthread_db enabled]
[New Thread 0xb7fd7730 (LWP 20138)]

Program received signal SIGSEGV, Segmentation fault.
PyString_AsString (op=<value optimized out>) at Objects/stringobject.c:726
726		if (!PyString_Check(op))
Missing separate debuginfos, use: debuginfo-install cyrus-sasl.i386 e2fsprogs.i386 expat.i386 fontconfig.i386 freetype.i386 gcc.i386 gtk-nodoka-engine.i386 keyutils.i386 krb5.i386 libX11.i386 libXau.i386 libXcomposite.i386 libXcursor.i386 libXdmcp.i386 libXext.i386 libXfixes.i386 libXi.i386 libXrandr.i386 libXrender.i386 libcanberra.i386 libidn.i386 libogg.i386 libpng.i386 libselinux.i386 libssh2.i386 libtool.i386 libvorbis.i386 libxcb.i386 nspr.i386 nss.i386 openldap.i386 openssl.i686 pixman.i386 pygobject2.i386 zlib.i386
(gdb) where
#0  PyString_AsString (op=<value optimized out>) at Objects/stringobject.c:726
#1  0x00fa0d8a in pst_set_error (err=0xbffff2b4) at pst-helpers.c:398
#2  0x00fa1eab in plugin_init (err=0xbffff2b4) at pst-main.c:134
#3  0x0806ac62 in st_plugin_constructor (type=136398952, 
    n_construct_properties=2, construct_params=0x82128f8) at st-plugin.c:253
#4  0x00bf17a6 in IA__g_object_newv (object_type=<value optimized out>, 
    n_parameters=<value optimized out>, parameters=<value optimized out>)
    at gobject.c:1205
#5  0x00bf23e2 in IA__g_object_new_valist (object_type=<value optimized out>, 
    first_property_name=<value optimized out>, var_args=<value optimized out>)
    at gobject.c:1309
#6  0x00bf252e in IA__g_object_new (object_type=<value optimized out>, 
    first_property_name=Could not find the frame base for "IA__g_object_new".
) at gobject.c:1050
#7  0x0806a67e in st_plugin_new (
    filename=0x8211710 "/usr/lib/streamtuner/plugins/python.so", only_info=0)
    at st-plugin.c:302
#8  0x0806b517 in st_plugins_scan () at st-plugins.c:115
#9  st_plugins_scan_or_warn (dirname=0x808bcc7 "/usr/lib/streamtuner/plugins")
    at st-plugins.c:153
#10 0x0806b7d2 in st_plugins_load () at st-plugins.c:69
#11 0x08068663 in main (argc=0, argv=Cannot access memory at address 0x4
) at st-main.c:116
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[tbl@localhost ~]$ 



Version-Release number of selected component (if applicable):
streamtuner-0.99.99-17.fc9.i386

How reproducible:
Every time.....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Schwendt 2008-11-09 17:22:14 EST
PyString_AsString is inside libpython not streamtuner (and failing
in a PyObject type check). Skimming over the code path, I see no
obvious error in using the Python C API. And I can't reproduce it
with Rawhide. (Rebuilds might have fixed it.)

Is this still an issue?
Comment 2 Tom London 2008-11-09 19:13:41 EST
No, I can no longer reproduce.  In addition, I have converted to x86_64 system.

I'll close.

Note You need to log in before you can comment on or make changes to this bug.