Bug 457811 - FEAT: RHEL 4.8 - Updated cciss controller for new Controllers
FEAT: RHEL 4.8 - Updated cciss controller for new Controllers
Status: CLOSED DUPLICATE of bug 454643
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
medium Severity high
: rc
: 4.8
Assigned To: Red Hat Kernel Manager
Martin Jenner
: FutureFeature, HardwareEnablement, OtherQA
Depends On:
Blocks: 453976 461304
  Show dependency treegraph
 
Reported: 2008-08-04 15:28 EDT by Sandy Garza
Modified: 2009-06-20 01:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 17:52:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change the names of latest generation controllers. (5.27 KB, patch)
2008-08-04 15:39 EDT, Mike Miller (OS Dev)
no flags Details | Diff
Patch to update controller names, fix bug, add 2 new controllers (6.05 KB, patch)
2008-12-08 14:35 EST, Mike Miller (OS Dev)
no flags Details | Diff

  None (edit)
Description Sandy Garza 2008-08-04 15:28:28 EDT
1.  Feature Name:  Short, descriptive, unique name
	Updated cciss driver to support new Smart Array Controllers

2.  Description:  
	Include latest driver for new controller support

Architectures (mark all that apply) 
32-bit x86  
64-bit AMD64/Intel EM64T 

 Dependencies: 
 External links: 
 Priority (H,M,L):  High
 Target Releases:  RHEL 4.8
 Target Release Date: 
 Drivers or hardware dependency:  
 Target Kernel: 

3. 	Business Justification:
a. Why is this feature needed?   To support new controllers 
b. What hardware does this enable?   storage
c. Forecast, volume or high end platform? 
d. Any configuration info? 
e. When needed? 
f. Are there other dependencies (drivers). 

4. 	Status: 
a. Is code accepted upstream?  
    If so, what version or patch? 

5.   Hardware to Red Hat?

--- Additional comment from mschmidt@redhat.com on 2008-05-20 10:05:58 EDT ---

*** Bug 446755 has been marked as a duplicate of this bug. ***

--- Additional comment from mike.miller@hp.com on 2008-07-16 16:44:56 EDT ---

Created an attachment (id=311995)
Update new controller names

This patch updates the names of 5 new controllers and removes 5 that were
cancelled. Please consider this for 5.3.

--- Additional comment from mike.miller@hp.com on 2008-07-16 16:54:18 EDT ---

Created an attachment (id=312000)
Patch to dynamically set queue depth

This patch changes the way we set queue depth for each controller. Instead of
arbitrarily assigning some value we now read the controller config table to
determine how many commands are supported by the controller. We then subtract 4
to leave room for ioctls. The latest controllers added support a mode of
operation called Zero Memory Raid (ZMR). In this mode they only support 64
commands. So under load the user is bombarded with annoying "fifo full"
messages. We also spin until something completes so IO becomes backed up and
system performance is very poor. This is a bug fix. Please consider this for
inclusion in 5.3.
Comment 1 Mike Miller (OS Dev) 2008-08-04 15:39:39 EDT
Created attachment 313396 [details]
Change the names of latest generation controllers.

This patch removes 5 proposed new controllers and changes the marketing name of the remainig 5.
Comment 2 RHEL Product and Program Management 2008-09-03 09:11:18 EDT
Updating PM score.
Comment 3 Mike Miller (OS Dev) 2008-12-08 14:35:50 EST
Created attachment 326168 [details]
Patch to update controller names, fix bug, add 2 new controllers

This patch updates controller names and adds 2 new controllers. Those names/IDs are already upstream. It also addresses a bug for the P700m controller and all later controllers. The entry for the P700m was missing in the product table. The previous patch also addressed this bug but was not documented as such. 
Please use this patch for Update 8.
Comment 5 RHEL Product and Program Management 2009-03-12 14:57:21 EDT
Since RHEL 4.8 External Beta has begun, and this bugzilla remains 
unresolved, it has been rejected as it is not proposed as exception or 
blocker.
Comment 6 Sandy Garza 2009-04-08 17:52:31 EDT
This patch was rolled into the main cciss BZ for 4.8, 454643. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 454643 ***

Note You need to log in before you can comment on or make changes to this bug.