Bug 457836 - Beamer slides rendered incorrectly
Summary: Beamer slides rendered incorrectly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-texmf
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 437375
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-04 20:48 UTC by Jens Hardings
Modified: 2013-07-02 23:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-21 10:58:55 UTC
Type: ---


Attachments (Terms of Use)

Description Jens Hardings 2008-08-04 20:48:18 UTC
Description of problem:

Since I upgraded to Fedora core 9, and from teTeX (using pdftex version 1.21a) to texlive (using pdftex version 1.40.3 with poppler), the beamer presentations are not being rendered correctly any more.

When using rounded and shadowed blocks in a presentation, the plain text
and text in description environments gets represented in grey instead of
black. This happens only if a block environment is present, and affects
all text after that block environment (even on following frames).

Has been tested on another system using pdftex 1.40.x without libpoppler and did not show the problems presented here.

How reproducible:

always.

Steps to Reproduce:
1. Create a file with the following content:
**********************************************************************
\documentclass{beamer}

\mode<presentation>
{
  \usetheme{Darmstadt}
}

\begin{document}

 \begin{frame}
 \frametitle{Testing}

\begin{description}
\item[Black] This text gets displayed OK.
\end{description}

Plain text also works OK here.

\begin{block}{Test 1}
\begin{description}
\item[Black] This text gets displayed black.
\end{description}
\end{block}

\begin{description}
\item[Gray] This text gets displayed gray, but should be black.
\end{description}

Plain text also is affected.

\begin{itemize}
 \item This works well, though.
\end{itemize}

\begin{enumerate}
 \item Ditto.
\end{enumerate}

\end{frame}


\end{document}
**********************************************************************
2. Run pdflatex or latex on the file
3. View the result
4. Compare with results of the same file on Fedora core 8 with teTeX, or on RHEL 5.2.
  
Actual results:

Specific areas are displayed in gray (shaded out) instead of main color.

Expected results:


Additional info: Discussion list on latex-beamer: http://sourceforge.net/mailarchive/forum.php?thread_name=1216741358.9318.30.camel%40puc.hardings.cl&forum_name=latex-beamer-users

Comment 1 Tim Niemueller 2008-08-20 17:07:31 UTC
This bug is fixed in newer beamer versions. The Debian bug tracker has discussion with upstream at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=394792.

This bug is closely related to bug #437375. The fix for this bug is even mentioned in the posted changelog. Thus making this bug depend on that one.

Comment 2 Jens Hardings 2008-08-21 14:58:19 UTC
Effectively, the fix mentioned in the debian bug tracker solved the problem for me. Thanks a lot.

Comment 3 Jindrich Novy 2008-08-27 13:50:31 UTC
Applied. Thanks for the debian bug reference!

Comment 4 Michal Jaegermann 2008-10-12 05:21:00 UTC
Any chance that we will see fixed packages in F9?
My wife just tried to kill me due to this bug. :-)
A fix mentioned in comment #1 did work, though.
Thanks for that!

Comment 5 Tim Niemueller 2008-10-12 12:52:52 UTC
Jindrich, would you mind to build the latest version for F-9?

Comment 6 Jindrich Novy 2008-10-15 10:08:08 UTC
Please test the following update if you have a while:
https://admin.fedoraproject.org/updates/texlive-2007-32.fc9,texlive-texmf-2007-24.fc9

It should finally fix this and couple of other issues :)

Comment 7 Fedora Update System 2008-10-20 20:29:35 UTC
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texlive-texmf texlive'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8931

Comment 8 Michal Jaegermann 2008-10-21 19:56:49 UTC
With texlive-2007-32.fc9 packages which showed up in "testing" this
now works as expected.

Comment 9 Fedora Update System 2008-11-21 10:58:27 UTC
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.