Bug 457842 - Setting DN from a preop add plugin
Setting DN from a preop add plugin
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
All Linux
low Severity medium
: pre-dev-freeze
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 389_1.3.0 512820 690319
  Show dependency treegraph
 
Reported: 2008-08-04 18:20 EDT by Dave Sullivan
Modified: 2016-03-17 13:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 13:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2008-08-04 18:20:31 EDT
Description of problem:

Changing the DN in an add preop is not really supported, but it can be done, just not with public interfaces (proto-slap.h).  Please file a bug to have the operation_set/get target spec routines moved to the public interface file.


Version-Release number of selected component (if applicable):

Directory Server 8.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Getting and Setting the DN of an Entry

You can call the following two front-end routines to get and set the DN for an entry:

    * To get the DN for an entry, call the slapi_entry_get_dn() function.
    * To set the DN for an entry, call the slapi_entry_set_dn() function. 

Doing this within a preop_add causes an error and the causes the slap pid to become dead.
Comment 2 Rich Megginson 2012-01-09 14:25:27 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/217
Comment 5 Noriko Hosoi 2016-03-17 13:33:56 EDT
Per triage: No plan to fix this in the short term.

Note You need to log in before you can comment on or make changes to this bug.