Bug 457867 - Core Perl 5.10.0 CPANPLUS depends on not provided IPC::Run
Core Perl 5.10.0 CPANPLUS depends on not provided IPC::Run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 22:34 EDT by Jon Jensen
Modified: 2008-08-08 10:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 03:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Jensen 2008-08-04 22:34:19 EDT
Description of problem: The Fedora rawhide core Perl 5.10.0 includes CPANPLUS, and the RPM specfile says it depends on IPC::Run, but IPC::Run isn't included in core Perl anymore, so that makes a core Perl dependency on a non-core package, with no way to provide it.

But it looks like IPC::Run may only be needed by CPANPLUS on Win32 anyway, as removing the dependency solves the install problem and CPANPLUS worked fine in my (limited) tests.

It seems either the IPC::Run dependency of CPANPLUS should be removed from the RPM spec file, or else IPC::Run should be included.
Comment 1 Marcela Mašláňová 2008-08-05 03:34:32 EDT
Thank you for report. You are right, IPC::Run isn't needed.
Comment 2 Stepan Kasal 2008-08-08 10:03:07 EDT
Note: the dependency has been removed in version perl-5.10.0-40.fc10, i.e., in perl-CPANPLUS-0.84-40.fc10.

Note You need to log in before you can comment on or make changes to this bug.