This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 457878 - Shouldn't launch network creator if not connected to hypervisor.
Shouldn't launch network creator if not connected to hypervisor.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 02:15 EDT by Russell Coker
Modified: 2009-12-14 16:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:21:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log as requested (1.07 KB, application/x-gzip)
2008-09-16 18:31 EDT, Russell Coker
no flags Details
Don't set 'net add' button sensitive if not connected to hypervisor. (1.85 KB, text/plain)
2008-09-18 12:23 EDT, Cole Robinson
no flags Details

  None (edit)
Description Russell Coker 2008-08-05 02:15:23 EDT
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/RHEL510/pdf/Virtualization.pdf

I am trying to create a new virtual network as described on pages 71 to 78 (Red Hat numbering) of the above document (that's pages 77 to 84 PDF numbering).

When I get to the stage of clicking on the "forward" button for the final time (as shown in figure 17.47) nothing happens.

For "naming your virtual network" I entered "network1" (the suggested value).  At every other screen I just click on "forward" to accept the default values.  So with the most default possible configuration it doesn't work.  I've also tried other values with the same result.
Comment 1 Cole Robinson 2008-09-16 15:54:51 EDT
Can you provide ~/.virt-manager/virt-manager.log? I can't reproduce this. Using 'network1' and all the default values works for me.

Oh, I should ask, are you 'connected' to the xen hypervisor? As in, when you start the app, are you double clicking the 'xen' entry in the manager window first, or just going straight to host details?
Comment 2 Russell Coker 2008-09-16 18:31:15 EDT
Created attachment 316913 [details]
virt-manager.log as requested
Comment 3 Cole Robinson 2008-09-16 19:40:41 EDT
Hmm, that attachment unzipped fine, but the log seems to be only garbage. Not sure what happened. Can you repost?
Comment 4 Cole Robinson 2008-09-17 10:31:59 EDT
Okay, after talking offline, it turns it virt-manager wasn't connected to the hypervisor.

Changing this bug to track disabling the Virtual Network details section if we aren't connected to the hypervisor to avoid this confusion.
Comment 5 Cole Robinson 2008-09-18 12:23:52 EDT
Created attachment 317091 [details]
Don't set 'net add' button sensitive if not connected to hypervisor.

Equivalent functionality currently upstream.
Comment 6 Jay Turner 2008-09-19 10:43:31 EDT
QE ack for RHEL5.3.
Comment 10 errata-xmlrpc 2009-01-20 16:21:11 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html

Note You need to log in before you can comment on or make changes to this bug.