Bug 457881 - llvm-devel package needs to include Makefile.{common,rules,config}
llvm-devel package needs to include Makefile.{common,rules,config}
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 03:03 EDT by Eric Smith
Modified: 2009-04-11 08:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 20:34:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2008-08-05 03:03:54 EDT
Description of problem:

In order to build programs that use LLVM libraries, it is normally required that the client's Makefile include LLVM's Makefile.common and Makefile.config (derived when LLVM is configured), and Makefile.common includes Makefile.rules.  Thus these three files should be packaged in the -devel package.

For instance, the llvm-doc package includes an examples directory, but the examples cannot be compiled without the missing Makefiles.

In addition to including the makefiles in llvm-devel, the llvm-doc package should have a symlink from /usr/share/doc/llvm-doc-2.2/examples/Makefile.common to the location at which llvm-devel installs that file.

Version-Release number of selected component (if applicable):  2.2

How reproducible:  100%

Steps to Reproduce:
1.  cd /usr/share/doc/llvm-doc-2.2/examples
2.  make
  
Actual results:

make fails due to missing include files

Expected results:

make succeeds (or at least fails due to lack of permissions to write to the /usr/share/doc/llvm-doc-2.2 directory tree)

Additional info:
Comment 1 Bug Zapper 2008-11-25 21:39:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michel Alexandre Salim 2009-03-04 15:40:09 EST
Assigning to myself, update will be issued to close this and another bug.
Comment 3 Fedora Update System 2009-03-04 19:50:37 EST
llvm-2.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/llvm-2.4-3.fc10
Comment 4 Michel Alexandre Salim 2009-03-04 20:34:56 EST
Retracting the update: it appears that, even with the Makefile.*, the examples cannot be built without the full LLVM build directories.

Packaging this, or reworking the build scripts, is probably not worth it: people whose modules will be incorporated in LLVM will be building LLVM from an SVN checkout anyway.
Comment 5 Eric Smith 2009-04-11 08:56:34 EDT
Basically you've just argued that there's no point to having an llvm-devel package.  I disagree.  The llvm-devel package should be provided, and it should contain the files necessary to build things that depend on llvm.  Otherwise it will not be possible to properly build Fedora RPMs for other packages that depend on llvm.

Note You need to log in before you can comment on or make changes to this bug.