Bug 457897 - Missing header file stropts.h under /usr/include/sys
Missing header file stropts.h under /usr/include/sys
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 05:33 EDT by Hao Liu
Modified: 2016-11-24 10:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-09 19:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hao Liu 2008-08-05 05:33:43 EDT
Description of problem:
I'm trying to build test cases for lsb-test-core, it failed because there's a header file called stropts.h missing.

Version-Release number of selected component (if applicable):
lsb-test-core-3.2.0-2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Get and install lsb-tet3-lite-devel from http://www.linuxfoundation.org/download/#impl 
2. #rpm -ivh lsb-test-core-3.2.0-2.src.rpm
3. #cd /usr/src/redhat/SPECS
4. #rpmbuild -bp lsb-test-core.spec 
5. #cd ../BUILD/lsb-test-core-3.2.0
6. #./install.sh
7. #su - vsx0
8. $../setup.sh
  
Actual results:
Error message said: 
  userintf.c:592:25: error: sys/stropts.h: No such file or directory

Expected results:
Build and execute test cases to the end

Additional info:
# uname -a 
Linux dhcp-65-102.nay.redhat.com 2.6.25.11-97.fc9.i686 #1 SMP Mon Jul 21 01:31:09 EDT 2008 i686 i686 i386 GNU/Linux
Comment 1 Hao Liu 2008-08-05 06:03:05 EDT
there're lots errors in the previous "Description", here's a revised one:

Description of problem:
I'm trying to build test cases for lsb-test-core, it failed because there's a
header file called stropts.h missing.

Version-Release number of selected component (if applicable):
glibc-2.8-8.i686

How reproducible:
Always

Steps to Reproduce:
hostname: dhcp-65-86.nay.redhat.com
user: root
password: 
user: vsx0
passwowrd: 

1. #cd /usr/src/redhat/BUILD/lsb-test-core-3.2.0
2. #./install.sh
3. #su - vsx0
4. $../setup.sh

Actual results:
Error message said: 
  userintf.c:592:25: error: sys/stropts.h: No such file or directory

Expected results:
Build and execute test cases to the end

Additional info:
# uname -a 
Linux dhcp-65-102.nay.redhat.com 2.6.25.11-97.fc9.i686 #1 SMP Mon Jul 21
01:31:09 EDT 2008 i686 i686 i386 GNU/Linux
Comment 2 Ulrich Drepper 2008-08-09 19:15:36 EDT
Streams are optional in POSIX and not at all implemented in Linux.  There is no reason to install the file and we don't.  If the LSB dummies put this in their testsuite then contact them to change it.

Note You need to log in before you can comment on or make changes to this bug.