Bug 457898 - quota, edquota, setquota do not recognize "-h" option
quota, edquota, setquota do not recognize "-h" option
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: quota (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 05:36 EDT by Milos Malik
Modified: 2008-08-19 07:52 EDT (History)
0 users

See Also:
Fixed In Version: quota-3.14-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 07:52:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-08-05 05:36:50 EDT
Description of problem:
quota, edquota and setquota do not recognize command line option "-h" even if their help messages claim the opposite.

Version-Release number of selected component (if applicable):
quota-3.14-1

How reproducible:
Always

Steps to Reproduce:
$ /usr/bin/quota --help 2>&1 | grep help
-h, --help                display this help message and exit
$ /usr/bin/quota -h
quota: invalid option -- h
quota: Usage: quota [-guqvsw] [-l | -Q] [-i] [-F quotaformat]
        quota [-qvsw] [-l | -Q] [-i] [-F quotaformat] -u username ...
        quota [-qvsw] [-l | -Q] [-i] [-F quotaformat] -g groupname ...
        quota [-qvswugQ] [-F quotaformat] -f filesystem ...

-u, --user                display quota for user
-g, --group               display quota for group
-q, --quiet               print more terse message
-v, --verbose             print more verbose message
-s, --human-readable      display numbers in human friendly units (MB, GB...)
    --always-resolve      always try to translate name to id, even if it is
                          composed of only digits
-w, --no-wrap             do not wrap long lines
-l, --local-only          do not query NFS filesystems
-Q, --quiet-refuse        do not print error message when NFS server does
                          not respond
-i, --no-autofs           do not query autofs mountpoints
-F, --format=formatname   display quota of a specific format
-f, --filesystem-list     display quota information only for given filesystems
-h, --help                display this help message and exit
-V, --version             display version information and exit

Bugs to: jack@suse.cz
$ /usr/sbin/edquota --help 2>&1 | grep help
-h, --help                    display this help text and exit
$ /usr/sbin/edquota -h
/usr/sbin/edquota: invalid option -- h
edquota: Usage:
        edquota [-u] [-F formatname] [-p username] [-f filesystem] username ...
        edquota -g [-F formatname] [-p groupname] [-f filesystem] groupname ...
        edquota [-u|g] [-F formatname] [-f filesystem] -t
        edquota [-u|g] [-F formatname] [-f filesystem] -T username|groupname ...

-u, --user                    edit user data
-g, --group                   edit group data
-F, --format=formatname       edit quotas of a specific format
-p, --prototype=name          copy data from a prototype user/group
    --always-resolve          always try to resolve name, even if it is
                              composed only of digits
-f, --filesystem=filesystem   edit data only on a specific filesystem
-t, --edit-period             edit grace period
-T, --edit-times              edit grace time of a user/group
-h, --help                    display this help text and exit
-V, --version                 display version information and exit

Bugs to: jack@suse.cz
$ /usr/sbin/setquota --help 2>&1 | grep help
-h, --help                 display this help text and exit
$ /usr/sbin/setquota -h
/usr/sbin/setquota: invalid option -- h
setquota: Usage:
  setquota [-u|-g] [-F quotaformat] <user|group>
        <block-softlimit> <block-hardlimit> <inode-softlimit> <inode-hardlimit> -a|<filesystem>...
  setquota [-u|-g] [-F quotaformat] <-p protouser|protogroup> <user|group> -a|<filesystem>...
  setquota [-u|-g] [-F quotaformat] -b -a|<filesystem>...
  setquota [-u|-g] [-F quotaformat] -t <blockgrace> <inodegrace> -a|<filesystem>...
  setquota [-u|-g] [-F quotaformat] <user|group> -T <blockgrace> <inodegrace> -a|<filesystem>...

-u, --user                 set limits for user
-g, --group                set limits for group
-a, --all                  set limits for all filesystems
    --always-resolve       always try to resolve name, even if is
                           composed only of digits
-F, --format=formatname    operate on specific quota format
-p, --prototype=protoname  copy limits from user/group
-b, --batch                read limits from standard input
-t, --edit-period          edit grace period
-T, --edit-times           edit grace times for user/group
-h, --help                 display this help text and exit
-V, --version              display version information and exit

Bugs to: jack@suse.cz
  
Actual results:
3 "invalid option" messages + 3 help messages

Expected results:
3 help messages

Additional info:
Comment 1 john5342 2008-08-05 05:59:19 EDT
Also present in fedora 9
Comment 2 Fedora Update System 2008-08-05 11:03:19 EDT
quota-3.15-7.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-08-05 11:04:38 EDT
quota-3.14-2.fc8 has been submitted as an update for Fedora 8
Comment 4 Ondrej Vasik 2008-08-05 11:06:20 EDT
Thanks for report, fixed in rawhide, build for F8 and F9 updates, requested F9 stable, F8 testing (few additional bugfixes from F9 in this update).
Comment 5 Fedora Update System 2008-08-07 19:51:54 EDT
quota-3.15-7.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-08-07 19:55:51 EDT
quota-3.14-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update quota'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7085
Comment 7 Fedora Update System 2008-08-12 14:25:38 EDT
quota-3.14-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Ondrej Vasik 2008-08-19 07:52:17 EDT
Closing CURRENTRELEASE ... it looks like automatic closing bot is too lazy to do
that. Fixed in quota-3.14-2.fc8.

Note You need to log in before you can comment on or make changes to this bug.