Bug 457908 - libnl testing
libnl testing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Rebase
Depends On:
Blocks: 455793
  Show dependency treegraph
 
Reported: 2008-08-05 07:05 EDT by Tomas Pelka
Modified: 2013-02-18 23:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 23:54:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2008-08-05 07:05:58 EDT
Please include the folowing tests into next version of libnl (probably 1.1-1):

test-cache-mngr.c
test-genl.c
test-nf-cache-mngr.c
test-socket-creation.c

available via GIT (http://git.kernel.org/?p=libs/netlink/libnl.git;a=tree;f=tests;h=af6fe00fb21dd6451088967866cd1ecf0e484d82;hb=13ab2441ced84cfc093734b257c43fa468cb22fd)

The absence of tests cause symbol crashes.
Comment 8 Dan Williams 2009-11-12 15:09:43 EST
So since a rebase is unlikely due to libnl ABI breakage in 1.1, what exactly are are you asking for here Tomas?  Was there any particular reason you want the tests included?
Comment 9 Tomas Pelka 2009-11-13 02:35:43 EST
I would be glad that the tests were included in the code/package. The reason is that it will make libnl easier to test.

But it is up to you Dan, thanks.
Comment 10 Dan Williams 2009-11-19 01:31:43 EST
Ok; we'll probably need to backport the tests I guess since we probably aren't going to rebase for this cycle.  Punting to 5.6.
Comment 13 RHEL Product and Program Management 2010-08-09 15:46:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 Dan Williams 2013-02-18 23:54:11 EST
Pretty unlikely to happen for RHEL5, but in RHEL6 NM uses the system libnl so tests would have to go there.

Note You need to log in before you can comment on or make changes to this bug.