Bug 457911 - Buffer Overflow
Buffer Overflow
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cinepaint (Show other bugs)
10
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 07:29 EDT by Davide Repetto
Modified: 2009-12-18 01:16 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:16:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2008-08-05 07:29:18 EDT
Description of problem:
Buffer Overflow /Crash

Version-Release number of selected component (if applicable):
Cinepaint 0.22.1-7.fc9.i386

How reproducible:
Always. in Fedora 8, Fedora 9, and Rawhide on all 3 of my computers 

Steps to Reproduce:
1. Install cinepaint
2. Run cinepaint
  
Actual results:
cinepaind brifely opens its splash and dies

Expected results:
Display program window

Additional info:
$ cinepaint
Locale found in /usr/share/locale

(cinepaint:24586): Gtk-WARNING **: A floating object was finalized. This means that someone
called g_object_unref() on an object that had only a floating
reference; the initial floating reference is not owned by anyone
and must be removed with g_object_ref_sink().
        oyranos.c:197 oyGetPathFromProfileName_() 0,250000 Warning : profile sRGB.icc not found in colour path

cinepaint: Cannot open selected ICC assumed image profile: sRGB.icc
        oyranos.c:197 oyGetPathFromProfileName_() 0,250000 Warning : profile sRGB.icc not found in colour path

cinepaint: Cannot open selected ICC editing profile: sRGB.icc
        oyranos.c:217 oyGetPathFromProfileName_() 0,250000 Warning : profile "---" not found

*** buffer overflow detected ***: cinepaint terminated
======= Backtrace: =========
/lib/libc.so.6(__fortify_fail+0x48)[0x998c78]
/lib/libc.so.6[0x996d70]
/lib/libc.so.6[0x996468]
/lib/libc.so.6(_IO_default_xsputn+0xc8)[0x90ded8]
/lib/libc.so.6(_IO_vfprintf+0x133)[0x8e08b3]
/lib/libc.so.6(__vsprintf_chk+0xa7)[0x996517]
/lib/libc.so.6(__sprintf_chk+0x2d)[0x99645d]
cinepaint[0x807471c]
cinepaint[0x807583d]
cinepaint[0x8075c77]
cinepaint[0x8075eb7]
cinepaint[0x8078814]
cinepaint[0x8078dc5]
cinepaint[0x805af5c]
cinepaint[0x80d1b17]
/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x84)[0xcd88b4]
/lib/libgobject-2.0.so.0(g_closure_invoke+0x1ab)[0xccb12b]
/lib/libgobject-2.0.so.0[0xcdf995]
/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7fe)[0xce0ece]
/lib/libgobject-2.0.so.0(g_signal_emit+0x26)[0xce1336]
/usr/lib/libgtk-x11-2.0.so.0(gtk_button_clicked+0xa1)[0x39aae9]
/usr/lib/libgtk-x11-2.0.so.0[0x39bf4a]
/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x84)[0xcd88b4]
/lib/libgobject-2.0.so.0[0xcc98a9]
/lib/libgobject-2.0.so.0(g_closure_invoke+0x1ab)[0xccb12b]
/lib/libgobject-2.0.so.0[0xcdf1ee]
/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7fe)[0xce0ece]
/lib/libgobject-2.0.so.0(g_signal_emit+0x26)[0xce1336]
/usr/lib/libgtk-x11-2.0.so.0(gtk_button_released+0xa1)[0x39aa42]
/usr/lib/libgtk-x11-2.0.so.0[0x39bd3a]
/usr/lib/libgtk-x11-2.0.so.0[0x4a13f6]
/lib/libgobject-2.0.so.0[0xcc98a9]
/lib/libgobject-2.0.so.0(g_closure_invoke+0x1ab)[0xccb12b]
/lib/libgobject-2.0.so.0[0xcdf63d]
/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x688)[0xce0d58]
/lib/libgobject-2.0.so.0(g_signal_emit+0x26)[0xce1336]
/usr/lib/libgtk-x11-2.0.so.0[0x612d84]
/usr/lib/libgtk-x11-2.0.so.0(gtk_widget_event+0x115)[0x6128ac]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0x260)[0x49f9b3]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x2da)[0x49e49d]
/usr/lib/libgdk-x11-2.0.so.0[0x786fc0]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1e8)[0xc150d8]
/lib/libglib-2.0.so.0[0xc18783]
/lib/libglib-2.0.so.0(g_main_loop_run+0x1d2)[0xc18ca2]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xe0)[0x49dbc5]
cinepaint[0x80d24e5]
/lib/libc.so.6(__libc_start_main+0xe6)[0x8b85d6]
cinepaint[0x8058a21]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-00146000 r-xp 00000000 08:01 1243404    /usr/lib/libcinepaint.so.0.0.22
00146000-00149000 rw-p 00034000 08:01 1243404    /usr/lib/libcinepaint.so.0.0.22
00149000-0014a000 rw-p 00149000 00:00 0 
0014a000-0018c000 r-xp 00000000 08:01 1243425    /usr/lib/libcinepaintHalf.so.0.0.22
0018c000-0018d000 rw-p 00041000 08:01 1243425    /usr/lib/libcinepaintHalf.so.0.0.22
0018d000-0019b000 r-xp 00000000 08:01 1243270    /usr/lib/liboyranos_moni.so.0.1.7
0019b000-0019c000 rw-p 0000d000 08:01 1243270    /usr/lib/liboyranos_moni.so.0.1.7
0019c000-001cb000 r-xp 00000000 08:01 1243236    /usr/lib/liboyranos.so.0.1.7
001cb000-001cc000 rw-p 0002f000 08:01 1243236    /usr/lib/liboyranos.so.0.1.7
001cc000-001d2000 r-xp 00000000 08:01 1243095    /usr/lib/libXrandr.so.2.1.0
001d2000-001d3000 rw-p 00005000 08:01 1243095    /usr/lib/libXrandr.so.2.1.0
001d3000-0025a000 r-xp 00000000 08:01 1242952    /usr/lib/libfreetype.so.6.3.16
0025a000-0025e000 rw-p 00086000 08:01 1242952    /usr/lib/libfreetype.so.6.3.16
0025e000-0026e000 r-xp 00000000 08:01 1242776    /usr/lib/libelektra.so.2.0.2
0026e000-0026f000 rw-p 0000f000 08:01 1242776    /usr/lib/libelektra.so.2.0.2
0026f000-00279000 r-xp 00000000 08:01 1687601    /lib/libnss_files-2.8.so
00279000-0027a000 r--p 0000a000 08:01 1687601    /lib/libnss_files-2.8.so
0027a000-0027b000 rw-p 0000b000 08:01 1687601    /lib/libnss_files-2.8.so
0027b000-0027c000 r-xp 00000000 08:01 1320551    /usr/lib/gconv/ISO8859-1.so
0027c000-0027d000 r--p 00000000 08:01 1320551    /usr/lib/gconv/ISO8859-1.so
0027d000-0027e000 rw-p 00001000 08:01 1320551    /usr/lib/gconv/ISO8859-1.so
00282000-0028b000 r-xp 00000000 08:01 1243154    /usr/lib/libXcursor.so.1.0.2
0028b000-0028c000 rw-p 00008000 08:01 1243154    /usr/lib/libXcursor.so.1.0.2
0028e000-002aa000 r-xp 00000000 08:01 1239931    /usrcinepaint terminated: sigabrt caught

(cinepaint:24586): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(cinepaint:24586): Gtk-CRITICAL **: gtk_object_destroy: assertion `object != NULL' failed

(cinepaint:24586): Gtk-CRITICAL **: gtk_object_unref: assertion `GTK_IS_OBJECT (object)' failed
Comment 1 Nicolas Chauvet (kwizart) 2008-08-05 08:01:07 EDT
This problem doesn't appear with me on two different systems:
Fedora 9 i686 with radeon (EXA render been activated)
Fedora 8 x86_64 with nVidia.

Do you have installed (or installed and removed) packages that wasn't provided via the fedora repositories ?
What is the full output of:
yum list extras
Was your system fully updated ? (yum update was run ?)

Did you tried to remove the user prefs directory :
rm ~/.cinepaint/* -rf ?

On which hardware do you have it tested ? (CPU, GPU and driver).
Comment 2 Davide Repetto 2008-08-06 05:59:42 EDT
Hy, I did done some homeworks.

I installed a pristine Fedora 9 with all the defaults untouched (english language included) and cinepaint worked.

I installed another clean Fedora 9, only this time with Italian as the system default language, and there cinepaint died.

The same happens with fedora 8 and Rawhide. If the OS default locale is Italian, cinepaint dies with a stack overflow.

It appears to be CPU/Vga and release independent.

You may want to check other languages as well, but I suspect that fixing Italian will fix them all...
Comment 3 Nicolas Chauvet (kwizart) 2008-08-06 06:30:07 EDT
Instead of re-installing Fedora in english, you might test if cinepaint hangs while running it with :
LANG=C cinepaint

Cinepaint seems to have italian locale support. But oyranos and icc_examin support for italian seems to miss, maybe that's related.
I will suggest the icc_examin maintainer to add it to transifex
https://translate.fedoraproject.org/submit/
Would you be interested to maintain such localization ?

Now maybe the project settle somewhere else...
Comment 4 Davide Repetto 2008-08-06 09:32:12 EDT
Yes, of course, with "LANG=C cinepaint" it works.

As per the localization of icc_examin, I'm not much of a language guy and I just hate doing translations. :) But I guess I could give it a shot if it's badly needed. Though, I'm not willing to go beyond the initial translation effort.

Looking at the ".po" files I see some confusion with licenses and copyrights... Maybe the author has to do some cleanups in that field before someone else feels confident about contributing his own work.


> Now maybe the project settle somewhere else...

This, I don't undestand... :-?
Comment 5 Bug Zapper 2008-11-25 21:39:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-11-18 02:53:34 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-12-18 01:16:52 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.