Bug 457941 - Remove /etc/mtab from /etc/rwtab
Remove /etc/mtab from /etc/rwtab
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: K12LTSP
  Show dependency treegraph
 
Reported: 2008-08-05 12:47 EDT by Warren Togami
Modified: 2014-03-16 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 13:43:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-08-05 12:47:09 EDT
Please remove /etc/mtab from the default /etc/rwtab shipped in initscripts.

Due to Bug #214891 /etc/mtab in rwtab was never useful.  Until that bug is fixed or we have union mounts, symlinking /etc/mtab to /proc/mounts is the standard for read-only roots.

With /etc/mtab in rwtab an ugly error message happens during boot.
Comment 1 Bug Zapper 2008-11-25 21:40:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.