Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 457990 - Abnormally sized fonts and windows
Summary: Abnormally sized fonts and windows
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: 10
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-06 00:24 UTC by David
Modified: 2018-04-11 18:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-25 12:48:17 UTC
Type: ---


Attachments (Terms of Use)
xorg log (23.16 KB, text/plain)
2008-08-06 00:24 UTC, David
no flags Details
Screenshot 1 (240.14 KB, image/png)
2008-08-06 00:25 UTC, David
no flags Details
Screenshot 2 (124.33 KB, image/png)
2008-08-06 00:26 UTC, David
no flags Details
xdpyinfo output (2.79 KB, text/plain)
2008-08-06 00:27 UTC, David
no flags Details

Description David 2008-08-06 00:24:33 UTC
Created attachment 313506 [details]
xorg log

Description of problem:
 
A fresh installation of Fedora 9 (also tried with xorg and kernel updated), on an Asus S6F, renders abnormally sized fonts and windows.



Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386



Expected results:

Normal window and font sizes.



Additional info:

X server log and screenshot are attached.

Graphics card is:

bash-3.2# lspci
...
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Comment 1 David 2008-08-06 00:25:34 UTC
Created attachment 313507 [details]
Screenshot 1

Comment 2 David 2008-08-06 00:26:08 UTC
Created attachment 313508 [details]
Screenshot 2

Comment 3 David 2008-08-06 00:27:00 UTC
Created attachment 313509 [details]
xdpyinfo output

Comment 4 David 2008-08-06 13:49:53 UTC
While googling and searching forums, I found out it's a DPI setting problem. As one can see in the attached xdpyinfo output, my system reports:

resolution:    141x140 dots per inch

and it should be 96x96.

By opening gnome-appearance-properties and in Tab Fonts, choosing details and changing resolution to 96 the problem is solved, at least on the surface, as everything looks normal again, but xdpyinfo still reports 141x140...

I'm still trying to find out how to manually set this to the correct value.

Comment 5 Matěj Cepl 2008-09-02 16:36:45 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 7 Matěj Cepl 2008-10-21 22:50:02 UTC
sorry, comment 5 doesn't make any sense to me as well.

Comment 8 Adam Jackson 2008-10-31 14:19:57 UTC
Can you attach the output of 'xrandr --prop'?  I'm curious what kind of EDID data we're getting.

Comment 9 Matěj Cepl 2008-11-27 14:21:04 UTC
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

Comment 10 David 2009-01-10 16:29:06 UTC
Hi, sorry not to reply earlier, but these bugzilla messages were being filtered to an IMAP folder I wasn't checking often now. I have now recently installed Fedora 10 but the problem persists even with all recent updates. Here's the output of the commands you request:

[root@ananda david]# rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
gstreamer-plugins-ugly-0.10.10-1.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-bad-extras-0.10.9-1.fc10.i386
nspluginwrapper-1.1.10-1.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
xulrunner-1.9.0.5-1.fc10.i386
PackageKit-yum-plugin-0.3.12-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386
plymouth-system-plugin-0.6.0-0.2008.11.17.3.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
firefox-3.0.5-1.fc10.i386
p7zip-plugins-4.61-1.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
flash-plugin-10.0.15.3-release.i386
PackageKit-gstreamer-plugin-0.3.12-1.fc10.i386
totem-mozplugin-2.24.3-1.fc10.i386
xulrunner-devel-1.9.0.5-1.fc10.i386

[root@ananda david]# xrandr --prop
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 1366 x 1366
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1366x768+0+0 (normal left inverted right x axis y axis) 246mm x 139mm
	EDID_DATA:
		00ffffffffffff003064405500000000
		2010010280190eff0a7fee9b5b528c25
		254d5600000001010101010101010101
		010101010101461e562a51000830406a
		1600f68b000000180000000f00048804
		88010201029195030400000000fe0054
		4d444953504c41590a202020000000fe
		004c5444313131455844410a2020009c
	PANEL_FITTING: full
		supported: center       full_aspect  full        
	BACKLIGHT_CONTROL: kernel
		supported: native       legacy       combination  kernel      
	BACKLIGHT: 15 (0x0000000f) range:  (0,15)
   1366x768       60.0*+
   800x600        60.3  
   640x480        59.9  
TV disconnected (normal left inverted right x axis y axis)
	BOTTOM: 37 (0x00000025) range:  (0,100)
	RIGHT: 46 (0x0000002e) range:  (0,100)
	TOP: 36 (0x00000024) range:  (0,100)
	LEFT: 54 (0x00000036) range:  (0,100)
	TV_FORMAT: NTSC-M
		supported: NTSC-M       NTSC-443     NTSC-J       PAL-M       
		           PAL-N        PAL

Comment 11 Vedran Miletić 2009-11-05 23:11:26 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, including Intel driver, which may have resolved this issue.
To be more precise, Intel has undergone a major rewrite during Fedora 10, 11 and 12 cycles, and whole driver is working a lot better now. Users who have experienced this problem are encouraged to retry with at least Fedora 12 Beta and see if the issue is still relevant.

Please, if you experience this problem on Fedora 12 Beta or up-to-date system running Rawhide, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

We hope to see how many older bugs in Intel driver are still relevant today, in hope that most of them were fixed in rewrite process.

[This is a bulk message for all open Fedora 10 i810-related bugs (39 of them are still open). I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 12 Bug Zapper 2009-11-18 08:14:37 UTC
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 David 2009-11-25 12:48:17 UTC
I just tried Fedora 12 Live CD and this problem is solved. Fonts and windows are in the correct size so this bug can be closed as fixed. I changed the state to CLOSED CURRENTRELEASE. Is this ok?


Note You need to log in before you can comment on or make changes to this bug.