Bug 4580 - %doc - silent failure when a file is missing
Summary: %doc - silent failure when a file is missing
Status: CLOSED DUPLICATE of bug 3230
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-18 08:04 UTC by benedict
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-30 23:28:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description benedict 1999-08-18 08:04:14 UTC
When processing the %files list, if a %doc file is missing
you get an error message, but the packaging goes on and
rpm exists normally.

The resulting package contains all %doc files mentione
before the one that's missing, and doesn't contain any
%doc files mentioned later.

Silent failures are no good!

Comment 1 Jeff Johnson 2001-02-21 18:42:19 UTC
FWIW, the silent failure has been considered a "feature" in legacy releases of
rpm.

I'm gonna dupe this bug onto the lack of scoping for %attr across %doc, as the
solution to both bugs will be the same (i.e. rewrite a tighter copy of %doc
files).

*** This bug has been marked as a duplicate of 3230 ***


Note You need to log in before you can comment on or make changes to this bug.