This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 458003 - Korean font breaks PDF generation
Korean font breaks PDF generation
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 461364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-05 23:18 EDT by Jeff Fearn
Modified: 2010-11-23 23:19 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.35
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 23:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-08-05 23:18:41 EDT
Description of problem:
The Korean font has been moved and it's failure to create a metrics file causes PDF generation to fail.

Version-Release number of selected component (if applicable):

publican-0.34

How reproducible:

Always

Actual results:

Generating metrics for: /usr/share/fonts/baekmuk-ttf-batang/batang.ttf
Error while building XML font metrics file.
java.io.FileNotFoundException: /usr/share/fonts/baekmuk-ttf-batang/batang.ttf (No such file or directory)

Expected results:
font metric file

Additional info:
The script that builds font metrics needs to die properly so broken packages don't get created.
Comment 1 Jeff Fearn 2008-08-05 23:41:59 EDT
Changed font path and Requires font name. Ensured font metric script dies properly if metric generation fails.
Comment 2 Jeff Fearn 2008-09-08 19:08:07 EDT
*** Bug 461364 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.