Bug 458042 - makewhatis error on file name with shell meta-characters
makewhatis error on file name with shell meta-characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 05:42 EDT by Patrick Monnerat
Modified: 2008-11-20 04:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 04:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Monnerat 2008-08-06 05:42:14 EDT
Description of problem:
When man-pages-fr is installed, file '/usr/share/man/fr/man8/ld-linux.so*.8.gz' exists, '*' being a name character and not a meta.
This causes weekly cron makewhatis to send the following report:

makewhatis: line 191: [: too many arguments
makewhatis: line 194: [: too many arguments


Version-Release number of selected component (if applicable):
man-1.6e-3.fc7
man-pages-fr-2.80.0-2.fc8

How reproducible:
Always, if such a weird file name exists.

Additional info:
Could be fixed by double-quoting references to shell variable 'x' in makewhatis script, lines 191, 194, 201
Comment 1 Patrick Monnerat 2008-10-06 12:35:29 EDT
ping ?
Comment 2 Ivana Varekova 2008-11-19 10:06:27 EST
Hello,
I can't reproduce the problem you describe - so please could you attach here the full weekly-cron-job-message and the list of all man-pages* packages which you have installed?
Comment 3 Patrick Monnerat 2008-11-19 10:52:42 EST
No, I can't: I do not have this installation anymore !
But I reproduced it just now manually as follows:

_ On F8, install man-pages-fr (current version is now 3.03.0-1, but it still contains file '/usr/share/man/fr/man8/ld-linux.so*.8.gz')
_ Issue the command "/usr/sbin/makewhatis /usr/share/man/fr"

You will get the two error lines mentionned above.
Comment 4 Ivana Varekova 2008-11-20 04:07:31 EST
Thanks - fixed in man-1.6f-13.fc11.

Note You need to log in before you can comment on or make changes to this bug.