Bug 458048 - Update jabberd rpm to 2.2.2
Update jabberd rpm to 2.2.2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jabberd (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 06:48 EDT by Bernie Innocenti
Modified: 2008-10-08 06:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 06:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for cvs (2.48 KB, patch)
2008-08-06 06:48 EDT, Bernie Innocenti
no flags Details | Diff

  None (edit)
Description Bernie Innocenti 2008-08-06 06:48:37 EDT
Created attachment 313550 [details]
patch for cvs

patch for spec file attached.
Comment 1 Bernie Innocenti 2008-08-06 06:49:51 EDT
Oh, I'm a Fedora developer, so if you approve the change I can commit and rebuild the package myself.
Comment 2 Adrian Reber 2008-08-07 12:12:38 EDT
In theory, yes. But I am having a problem with 2.2.1 that pidgin cannot connect to it: http://developer.pidgin.im/ticket/6394

So I will try your patch and if pidgin works with 2.2.2 I will commit your changes. I just do not want a broken jabberd in CVS.
Comment 3 Adrian Reber 2008-08-07 12:36:02 EDT
Sorry it still does not work with pidgin. Did you try it with pidgin?
Comment 4 Bernie Innocenti 2008-08-07 12:46:02 EDT
Pidgin 2.4.3 works nicely for me with jabberd 2.2.2.

Actually, I couldn't connect to the old jabberd in Fedora, and this is why I upgraded the rpm in the first place.  Then, I realized the problem was just that the mysql schema needed updating.  The update info is buried in a large changelog, and finding the problem was particularly nasty because the logs would not reveal anything.
Comment 5 Adrian Reber 2008-08-07 12:53:07 EDT
Ah, so it seems it is only a problem for me. That would be good. Are you using pidgin from F9? Are you using TLS?
Comment 6 Adrian Reber 2008-10-08 06:04:28 EDT
I just updated jabberd on the devel branch to 2.2.4.

jabberd 2.2.4 and pidgin 2.5.1 are finally working even if TLS is enabled.

I will also push an update to F9 soon, because F9 is still on 2.1.23 which is a pretty old development version.

Note You need to log in before you can comment on or make changes to this bug.