Bug 458071 - noisy %post from spinfinity plugin
Summary: noisy %post from spinfinity plugin
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: F10DesktopBlocker
TreeView+ depends on / blocked
 
Reported: 2008-08-06 13:36 UTC by Jesse Keating
Modified: 2013-01-10 03:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 00:57:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2008-08-06 13:36:44 UTC
During initial install, the plugin tries to set the default via /usr/sbin/plymouth-set-default-plugin, which apparently doesn't exist at this time.  This causes a scriptlet error.

Comment 1 Ray Strode [halfline] 2008-08-06 13:54:10 UTC
odd,

%package plugin-spinfinity
Summary: Plymouth "Spinfinity" plugin
Group: System Environment/Base
Requires: %name = %{version}-%{release}

and %{_sbindir}/plymouth-set-default-plugin is in the plymouth package.

This bug sort of smells like bug 214737, but I can't imagine plymouth being pulled in multilib and that bug is closed fixed now anyway.

Comment 2 Jesse Keating 2008-08-06 14:01:23 UTC
perhaps you missed the difference between Requires: and Requires(post): ?

Requires just means "this must pre-exist or be in the same transaction set"  whereas Requires(post) means "This must pre-exist or be installed prior to the %post script is ran"

Comment 3 Ray Strode [halfline] 2008-08-06 14:06:21 UTC
oh, right.  I knew that, fix coming shortly.

Comment 4 Orion Poplawski 2008-10-27 21:45:30 UTC
%post can still fail, though perhaps for a different reason:

Installing plymouth-scripts-0.6.0-0.2008.10.24.2.fc10.x86_64
Installing plymouth-plugin-spinfinity-0.6.0-0.2008.10.24.2.fc10.x86_64
warning: %post(plymouth-plugin-spinfinity-0.6.0-0.2008.10.24.2.fc10.x86_64) scriptlet failed, exit status 1
Installing plymouth-0.6.0-0.2008.10.24.2.fc10.x86_64

Something /usr/sbin/plymouth-set-default-plugin runs or a directory it needs?

Comment 5 Ray Strode [halfline] 2008-10-27 21:50:07 UTC
if you run it manually does it fail?

Comment 6 Orion Poplawski 2008-10-27 21:52:25 UTC
It runs fine on the installed system.

Comment 7 Luke Macken 2008-10-28 00:29:15 UTC
Getting this with todays rawhide.

/usr/lib/plymouth/spinfinity.so does not exist

error: %post(plymouth-plugin-spinfinity-0.6.0-0.2008.10.24.2.fc10.x86_64) scriptlet failed, exit status 1

Comment 8 Ray Strode [halfline] 2008-10-28 00:55:35 UTC
so i guess this is because plymouth isn't installed yet causing /usr/lib/plymouth not to exist.

Comment 9 Ray Strode [halfline] 2008-10-28 00:57:38 UTC
I've moved /usr/lib/plymouth to plymouth-libs


Note You need to log in before you can comment on or make changes to this bug.