Bug 458131 - RFE: include yum-fastestmirror plugin.
RFE: include yum-fastestmirror plugin.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 12:10 EDT by Aleksey Nogin
Modified: 2009-01-20 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0227 normal SHIPPED_LIVE yum-utils bug fix update 2009-01-20 11:06:29 EST

  None (edit)
Description Aleksey Nogin 2008-08-06 12:10:46 EDT
Currently RHEL does not include the yum-fastestmirror plugin. This makes sense as long as yum is only using with RHN; hower once other repositories, like EPEL, are in use, it would be nice to be able to use yum-fastestmirror.

I already filed a similar RFE against EPEL - bug 457978. It would have made more sense to include yum-fastestmirror in EPEL instead of RHEL, however since this plugin is a part of the yum-utils package that is already a part of RHEL, including it in EPEL is problematic per bug 457978 comment #1.
Comment 1 James Antill 2008-08-06 13:34:04 EDT
 Given that there a few plugins we don't distribute in RHEL, I think the correct fix is to have an EPEL yum-utils build that just produces the sub-packages we don't have in RHEL.

 However I think the reason fastestmirror wasn't included by default was: 1) It wasn't as well tested/fixed as it is now. 2) RHEL/RHN doesn't use it. 3) MirrorManager should (hopefully) eventually obviate the need for it.

 #1 isn't true anymore, so I think I'm going to include it for 5.3 (although not force it like CentOS).
Comment 2 RHEL Product and Program Management 2008-08-06 13:42:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2009-01-20 17:05:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0227.html

Note You need to log in before you can comment on or make changes to this bug.