Bug 458135 - Sort control message should not be logged for internal operations
Sort control message should not be logged for internal operations
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.1.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks: 249650 FDS112
  Show dependency treegraph
 
Reported: 2008-08-06 12:28 EDT by Nathan Kinder
Modified: 2015-01-04 18:33 EST (History)
3 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 19:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (1.61 KB, patch)
2008-08-06 12:28 EDT, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2008-08-06 12:28:05 EDT
Created attachment 313597 [details]
CVS Diffs

The backend plug-in currently attempts to log a message whenever it is processing a sort control as part of a search operation.  For an internal operation, this causes an error to be logged since the connection ID is not set for an internal operation, but the access log needs it for the log message.  Here is the error log message:

  [05/Aug/2008:13:12:34 -0700] - Connection is NULL and hence cannot access SLAPI_CONN_ID

When using the DNA plug-in, you will see lots of these messages since it does an internal sorted search.  We should not attempt to log anything related to the sort control in the access log for internal operations.
Comment 1 Nathan Kinder 2008-08-08 11:53:43 EDT
Checked into ldapserver (HEAD).  Thanks to Rich for his review!

Checking in back-ldbm/ldbm_search.c;
/cvs/dirsec/ldapserver/ldap/servers/slapd/back-ldbm/ldbm_search.c,v  <--  ldbm_search.c
new revision: 1.14; previous revision: 1.13
done
Comment 2 Jenny Galipeau 2009-04-02 11:00:05 EDT
Can I verify this by executing the DNA acceptance tests and verifying the errors log does not contain this message?  I could add regression test to this suite also.
Comment 3 Jenny Galipeau 2009-04-02 11:10:05 EDT
/s/errors/access/
Comment 4 Nathan Kinder 2009-04-02 11:13:14 EDT
Yes, check(In reply to comment #2)
> Can I verify this by executing the DNA acceptance tests and verifying the
> errors log does not contain this message?  I could add regression test to this
> suite also.  

Yes, you can verify by checking for the following message in the errors log during the DNA test.  It should not appear.

  [05/Aug/2008:13:12:34 -0700] - Connection is NULL and hence cannot access
SLAPI_CONN_ID
Comment 5 Jenny Galipeau 2009-04-02 11:17:18 EDT
fix verified DS 8.1 RHEL 5 - adding regression test to DNA acceptance test that will parse both replica's access logs for the error message.
Comment 6 Jenny Galipeau 2009-04-03 09:55:38 EDT
Test case added to acceptance tests is failing on RHEL 4 64bit and 32 bit with 2882 instances of the error in the access log.
Comment 7 Jenny Galipeau 2009-04-03 11:40:53 EDT
More investigation - RHEL 4 is problem with test - no actual messages in access log.
Comment 8 Chandrasekar Kannan 2009-04-29 19:05:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html

Note You need to log in before you can comment on or make changes to this bug.