Bug 458142 - matplotlib-0.98.3 released
matplotlib-0.98.3 released
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-matplotlib (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 13:13 EDT by Neal Becker
Modified: 2009-07-14 10:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
buggy fonts in plot with updated matplotlib (0:0.98.5.2-2.fc10) (32.89 KB, image/png)
2009-03-30 11:57 EDT, zingale
no flags Details
output with current matplotlib on fedora 10 (0:0.98.1-1.fc10) (32.65 KB, image/png)
2009-03-30 11:58 EDT, zingale
no flags Details

  None (edit)
Description Neal Becker 2008-08-06 13:13:59 EDT
Description of problem:
matplotlib-0.98.3 released

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Orion Poplawski 2008-08-18 13:57:27 EDT
Reassigning.
Comment 2 Jonathan Underwood 2009-03-08 10:27:00 EDT
Hi Jef - as you know, the current upstream version is 0.98.5.2 which you've got in the rawhide package, but not F-10. I've rebuilt the latest version on F10 and it works fine, and fixes many bugs. Any chance of updating the F-10 branch package?
Comment 3 Jef Spaleta 2009-03-08 18:58:09 EDT
Hmm I've been running it locally for awhile on my F10 box to make sure it didn't have a set of regressions..waiting for someone to ask for it.

I'm always a little wary about bumping scipy or matplotlib, since any regression is going to break people's home built scripts. Even if those "regressions" are really bug fixes.

I'll get it out to updates-testing today.
-jef
Comment 4 Jef Spaleta 2009-03-14 15:57:28 EDT
Sorry I got sidelined by a cold for a few days.  Update to testing has just been pushed.  

https://admin.fedoraproject.org/updates/python-matplotlib-0.98.5.2-2.fc10

This is a backport from F11, and includes the font policy changes to some extent. The package no longer includes its own fonts and depends on the dejavu package.  Please make sure default fonts are working correctly. To get non-default font families you'll need to install other system wide font packages.
Comment 5 Jonathan Underwood 2009-03-14 21:18:30 EDT
Tested and seems to work fine for me. Tested the DejaVu fonts are working by using this example program here:

http://matplotlib.sourceforge.net/examples/pylab_examples/font_table_ttf.html

and all seems well.

Thanks very much Jeff.
Comment 6 zingale 2009-03-30 11:56:27 EDT
I tried python-matplotlib.x86_64 0:0.98.5.2-2.fc10 (x86_64) from https://admin.fedoraproject.org/updates/F10/FEDORA-2009-2712, and plots come out fine, but LaTeX fonts (used via the standard r"$latex-here$" method) are all screwed up.

matplotlib-new.png shows a plot with python-matplotlib.x86_64 0:0.98.5.2-2.fc10.

matplotlib-orig.png shows the same plot with python-matplotlib.x86_64 0:0.98.1-1.fc10

So, it seems that the new matplotlib for F10 breaks the latex fonts that are used as part of that package.
Comment 7 zingale 2009-03-30 11:57:45 EDT
Created attachment 337227 [details]
buggy fonts in plot with updated matplotlib (0:0.98.5.2-2.fc10)
Comment 8 zingale 2009-03-30 11:58:40 EDT
Created attachment 337228 [details]
output with current matplotlib on fedora 10 (0:0.98.1-1.fc10)
Comment 9 zingale 2009-03-30 12:01:36 EDT
from my plotting routine, the axis labels are set as:

    pylab.xlabel(r"$t\,\,(\mathrm{s})$")
    pylab.ylabel(r"$T_\mathrm{peak}\,\,(\mathrm{K})$")
Comment 10 zingale 2009-03-30 13:47:44 EDT
looks like I pulled the trigger on this bug report too fast -- you need to delete your .matplotlib/ directory after updating, so the font caches are regenerated.  After doing that, it works fine.

Other upgraders will likely run into this problem though.
Comment 11 olga.moreira 2009-05-16 19:07:14 EDT
My problem with Latex fonts started since the update to python-matplotlib-0.98.5.2-2.fc10: .matplotlib directory deleted but it did not solve the problem (at least for me). Is the any other way of fixing the problem? I have tried pretty much everything.
Thank you in advance
Comment 12 Bug Zapper 2009-06-09 22:23:40 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-07-14 10:18:19 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.