Bug 458266 - Stop referring to non-existent CSS files (aka kill all 404 errors)
Summary: Stop referring to non-existent CSS files (aka kill all 404 errors)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 3.2
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-07 11:49 UTC by Tomas Hoger
Modified: 2013-06-24 04:09 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-12 20:53:06 UTC


Attachments (Terms of Use)

Description Tomas Hoger 2008-08-07 11:49:39 UTC
Description of problem:
Many Bugzilla pages refer to a lot of CSS files, some of them do not even exist on the bugzilla server, resulting in 404 server reply.

For example, when accessing show_bug.cgi and you already have all existing css files cached by the browser, 8 HTTP requests are sent to server 7 of which return 404 (I'm using Dusk skin):

https://bugzilla.redhat.com/skins/contrib/Dusk/yui/calendar.css

https://bugzilla.redhat.com/skins/contrib/Dusk/show_bug.css

https://bugzilla.redhat.com/skins/custom/global.css

https://bugzilla.redhat.com/skins/custom/yui/calendar.css

https://bugzilla.redhat.com/skins/custom/show_bug.css

https://bugzilla.redhat.com/skins/contrib/RedHat/show_bug.css

https://bugzilla.redhat.com/skins/contrib/RedHat/yui/calendar.css


Those requests are done for every page visit, adding to quite bad user experience wrt performance of new BZ.  Please either remove them from source, or create them on server as empty file, so browsers can cash them.

Comment 1 David Lawrence 2008-08-07 16:02:42 UTC
Unfortunately this is by design in the new BZ where it is looking for these css files in case the installation wants to override the standard stylesheets in the custom directory. We are looking into just fixing it to not look for those anymore as our installation doesn't need/use them.

Thanks
Dave

Comment 2 Frédéric Buclin 2008-08-07 22:48:08 UTC
These CSS files must exist. They are generated by checksetup.pl automatically. I have them all locally (except contrib/RedHat, of course).

Comment 3 Tomas Hoger 2008-08-08 06:28:11 UTC
Dave, so what about having them as empty files?  Can that break anything?

Comment 4 David Lawrence 2008-08-08 17:05:23 UTC
Checksetup.pl does in fact create these empty placeholder files. But we did not have them checked into CVS and since we generate rpm's for the live web servers based on what is in CVS and never actually run checksetupl.pl on the live servers, the files did not exist.

So I ran checksetup on an internal test box and have added the generated custom stylesheets to CVS so when we create a rpm for the next update, it will have them now.

This will be fixed in the next update.

Dave

Comment 5 David Lawrence 2008-08-08 21:28:12 UTC
Reopening. This is not fixed yet. There are still quite a few missing. Will work on this some more.

Dave

Comment 6 Tomas Hoger 2008-08-12 07:25:51 UTC
Dave, do you have any approximate ETA when such update is planned (days? weeks?).  Thank you!

Comment 7 David Lawrence 2008-08-12 20:53:06 UTC
Okay, I think I got all of the remaining 404s now. I have committed the fixes to CVS and will be in the next update (no later than thursday this week).

If you want to test the fix, go to https://bz-web2-test.devel.redhat.com (internal only).

Thanks
Dave


Note You need to log in before you can comment on or make changes to this bug.