Bug 458273 - <Tab> key selects the "Need info" checkbox when adding comments
<Tab> key selects the "Need info" checkbox when adding comments
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 08:56 EDT by Alexander Todorov
Modified: 2013-06-23 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 14:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-08-07 08:56:17 EDT
Description of problem:
When adding comments sometimes people use the <Tab> key to navigate to the submit button. This will go throught the need info checkbox which is right after the text entry field and will make it selected.

Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1. Focus the add comment text entry field
2. Navigate with <Tab> to the submit button

  
Actual results:
Need info checkbox is selected /and will change bug state also I guess/

Expected results:
Need info checkbox is not selected. It should be only selected when the user decides to do so, i.e. presses the <space> key

Additional info:
I think this is a regression against the previous version because it changes behavior and will cause many bugs to go into wrong state
Comment 1 Alexander Todorov 2008-08-07 08:57:35 EDT
The checkbox is selected after the focus moves to the "need info from" drop-down list.
Comment 2 David Lawrence 2008-08-08 14:19:37 EDT
This is because I was using onfocus for the javascript that automatically checks the box when the drop down or text field for needinfo info was focused. I have now changed it to onchange will will not automatically check the needinfo checkbox by simply tabbing across it. You will now have to choose a value from the drop down or type some text in the other field.

Committed and should show up in the next update.

Dave

Note You need to log in before you can comment on or make changes to this bug.