Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 458276 - Need mechanism to catch IRQ thread creation and re-run rtctl
Summary: Need mechanism to catch IRQ thread creation and re-run rtctl
Keywords:
Status: CLOSED DUPLICATE of bug 466929
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities
Version: 1.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-07 13:32 UTC by Clark Williams
Modified: 2008-11-20 21:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-20 21:29:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clark Williams 2008-08-07 13:32:43 UTC
Description of problem:
IRQ threads in the RT kernel are created when a driver registers an interrupt and are killed when the interrupt is unregistered. This means that if a module is reloaded, a new IRQ thread will be created, with it's default priority, as opposed to the desired priority specified in /etc/rtgroups. 

We need a mechanism to catch IRQ thread creation and re-run rtcl to adjust thread priorities.

Comment 1 Clark Williams 2008-11-20 21:29:23 UTC
same topic

*** This bug has been marked as a duplicate of bug 466929 ***


Note You need to log in before you can comment on or make changes to this bug.