Bug 458278 - Plymouth should not fail on headless systems (serial console)
Plymouth should not fail on headless systems (serial console)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-08-07 09:49 EDT by James Laska
Modified: 2013-09-02 02:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 09:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-08-07 09:49:02 EDT
Description of problem:

When installing F10-Alpha with an encrypted root device onto a IBM Power5 ppc system that does not have a vga adapter, the system appears to hang during boot up and not prompt for the passphrase.  There isn't anything obvious from the boot.log

During boot-up, plymouth and plymouthd appear to fail when run inside the initrd (encrypted root fs).

I have unpacked the initrd while in rescue-mode on the system, and run the /init script plymouth and plymouthd commands by hand.


Version-Release number of selected component (if applicable):

F10-Alpha, and the following updates:
 mkinitrd-6.0.58-1.fc10.ppc
 plymouth-0.5.0-12.2008.08.06.fc10.ppc


Steps to reproduce:

$ mkdir /tmp/initrd ; cd /tmp/initrd
$ zcat /boot/initrd... | cpio -id
$ ./bin/plymouthd
  <ctrl-z> and bg to background the process
$ ./bin/plymouth --show-splash
error: unexpectedly disconnected from boot status daemon


I have posted an strace from both:
 * the plymouthd cmd - http://jlaska.fedorapeople.org/plymouthd.strace
 * the plymouth cmd - http://jlaska.fedorapeople.org/plymouth.strace

How reproducible:
 * anytime I install with an encrypted root on a headless ppc system


Actual results:
 * system hangs during boot ... does not mount or prompt for encrypted root device

Expected results:
 * Normal boot
Comment 1 Ray Strode [halfline] 2008-08-07 09:58:49 EDT
So the important bit here:

26657 ioctl(10, GIO_CMAP, 0x1001a7d8)   = -1 EINVAL (Invalid argument)
26657 ioctl(10, PIO_CMAP, 0x1001a7d8)   = -1 EINVAL (Invalid argument)


We can't assume there's a terminal color map to twiddle, and fail fatally if there isn't.

We should also probably go straight to details view in that case, since serial console users probably always want the detailed boot information.
Comment 2 Ray Strode [halfline] 2008-08-26 09:38:09 EDT
This should work pretty well now.  (I'll need to do some more testing before release though)

Note You need to log in before you can comment on or make changes to this bug.