Bug 458280 - Split transmission package into libtransmission, transmission (gtk)
Split transmission package into libtransmission, transmission (gtk)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 09:52 EDT by Mukund Sivaraman
Modified: 2008-09-09 06:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 06:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mukund Sivaraman 2008-08-07 09:52:39 EDT
Description of problem:

The transmission package should be split into libtransmission (and -devel package) and transmission (for GTK program).

libtransmission is in a directory in the transmission release tarball, which can be used separately by 3rd party programs.

Please note that transmission and libtransmission (both in the same release tarball) are licensed differently.
Comment 1 Denis Leroy 2008-08-24 08:25:57 EDT
> The transmission package should be split into libtransmission (and -devel
> package) and transmission (for GTK program).

There are no development files or headers installed by transmission. Are you aware of any projects that are currently building on top of it ? (and if so, how do they link with transmission header files).

Unless there exists such a project, I don't see a good reason to split the current RPM, especially since it has a relatively small size (< 1MB). The dual licensing is not an issue, and will be properly documented in the license field of the version 1.33 spec file.

Note You need to log in before you can comment on or make changes to this bug.