Bug 458292 - No sound, segfaults with flash
No sound, segfaults with flash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 10:40 EDT by Tom London
Modified: 2008-08-08 00:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 00:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-08-07 10:40:15 EDT
Description of problem:
I get no sound playing flash objects, either with flash-plugin or with swfdec.

In addition, I see npviewer.bin segfaults in /var/log/messages:
Aug  7 07:23:49 localhost kernel: npviewer.bin[5111]: segfault at aaaaaaaa ip 0080c5f8 sp bfac6ca0 error 4 in libgobject-2.0.so.0.1706.0[7e3000+42000]
Aug  7 07:24:37 localhost kernel: npviewer.bin[5443]: segfault at aaaaaaaa ip 0080c5f8 sp bfa98c70 error 4 in libgobject-2.0.so.0.1706.0[7e3000+42000]
Aug  7 07:25:22 localhost kernel: npviewer.bin[5582]: segfault at aaaaaaaa ip 0080c5f8 sp bf972350 error 4 in libgobject-2.0.so.0.1706.0[7e3000+42000]

An example URL is 'http://nytimes.com'  [Big flash object about one screen down.]


Version-Release number of selected component (if applicable):
nspluginwrapper-1.1.0-5.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Togami 2008-08-07 13:20:35 EDT
If you are using Flash 9, then you need libflashsupport.i386 installed for sound to work.  There are known sound related race conditions in Flash 9 that can cause npviewer.bin to crash.

If you are using Flash 10 beta, it no longer needs libflashsupport.i386, however it triggers a bug in Firefox 3 causing firefox to crash.  This will be fixed in the upcoming firefox-3.0.2.
Comment 2 Tom London 2008-08-07 16:10:06 EDT
OK.  Thanks.  Running flash 9:
flash-plugin-9.0.124.0-release.i386
libflashsupport-000-0.5.svn20070904.i386

Installing libflashsupport.i386 indeed fixes the lack of sound. Thanks!

Per your message, I still get segfault, I believe when I close the tab....

Aug  7 13:04:14 localhost yum: Installed: libflashsupport-000-0.5.svn20070904.i386
Aug  7 13:06:32 localhost kernel: npviewer.bin[17145]: segfault at aaaaaaaa ip 0080c5f8 sp bfa07180 error 4 in libgobject-2.0.so.0.1706.0[7e3000+42000]
Comment 3 Warren Togami 2008-08-08 00:23:10 EDT
AFAIK the crashes you are experiencing are due to bugs in Flash 9 itself.  Nothing we can do about it.

Note You need to log in before you can comment on or make changes to this bug.