Bug 458300 - strace multilib in rawhide, conflicts on upgrade from F9
strace multilib in rawhide, conflicts on upgrade from F9
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-08-07 11:18 EDT by Matt Domsch
Modified: 2014-03-16 23:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 14:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2008-08-07 11:18:08 EDT
Description of problem:
strace in Fedora 9 allowed both i386 and x86_64 strace to be installed.  Upgrading from Fedora 9 to rawhide fails because of a file conflict between old strace.i386 and new strace.x86_64.  Removing strace.i386 lets the upgrade continue.
Comment 1 Roland McGrath 2008-08-24 22:56:28 EDT
If there is a problem here at all, it is not an strace issue, just a distro issue.  If you simultaneously upgrade to the same strace-V-R for both i386 and x86_64, then there is no problem.  If you had both arch rpms installed under F-9, I don't think that was done by normal distro means, since the x86_64 install image and repos do not contain strace.i386 rpms.  The report failed to show the actual conflict, which was a bad omission.  I tried it myself using rpm by hand (since there is no canonical distro way to make this happen AFAICT), and got the conflict on the man page file.  That differs because it changed between upstream strace versions, as you might expect.
Comment 2 Bill Nottingham 2008-10-24 14:51:12 EDT
strace only existed for the base arch in Fedora 9 (AFAICT). The same is true in F10. 

Closing; I'm curious how you got both arches installed under F9.

Note You need to log in before you can comment on or make changes to this bug.