Bug 458311 - RFE: email notification for *new* updates only.
RFE: email notification for *new* updates only.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-updatesd (Show other bugs)
5.5
All Linux
medium Severity low
: ---
: ---
Assigned To: James Antill
Red Hat Satellite QA List
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 11:38 EDT by Aleksey Nogin
Modified: 2012-10-30 10:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 10:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2008-08-07 11:38:26 EDT
With do_update = no and emit_via = email, once some updates become available, yum-updatesd starts generates a notification email on every single run. I come back to my email in the morning and see a large number of identical yum-updatesd messages, which is annoying. If for some reason I do not want to install the updates right away, it keeps bugging me.

If would be really nice to have an option of only getting an email when *new* updates are available - that is, when some of the available updates were not yet included in a previous notification email.
Comment 1 James Antill 2008-08-07 12:34:03 EDT
 Currently yum-updatesd doesn't store anything itself, this kind of feature would require that we store the "current updates" and diff it on the next run.

 This is unlikely to happen, esp. if it doesn't happen upstream first. I'll move this to rawhide ... but I wouldn't expect a quick resolution.
Comment 2 Jeremy Katz 2008-08-07 20:03:19 EDT
This is working exactly as its intended too.  Keeping some sort of state would basically entail leaving the rpmdb/yum state locked or serializing it in some way, which really isn't that interesting.
Comment 3 Aleksey Nogin 2008-08-08 12:18:58 EDT
Well, even if it's working as "intended", and improving it is not "interesting", this results in quite unpleasant end-user experience, including for paying RHEL users like me. I get yum-updatesd notifications from several different machines (they have different sets of packages installed, different channel subscription, etc, so I need separate notifications) and being "mailbomed" by all of them every time a common update is posted to RHN is quite annoying. Please reconsider the "WONTFIX".

P.S. IMHO, keeping state in a small text file in /var/cache/yum would not be a big deal.
Comment 4 James Antill 2008-08-08 12:44:53 EDT
 This BZ wasn't attached to any support request, which is why I moved it to Fedora.

 If you raise the request through the support channels you might get a different answer than the current one, even if _eventually_ it'll get back to me with a different BZ.
Comment 5 Aleksey Nogin 2008-08-08 13:25:38 EDT
OK, filed Service Request 1849028 on this.
Comment 6 Aleksey Nogin 2010-09-01 23:57:51 EDT
Still a big annoyance in RHEL 5.5 (especially when email notifications are enabled on several machines). Any chance this could be revisited?
Comment 8 Libor Miksik 2012-10-25 08:30:22 EDT
Thank you for submitting this issue for consideration. Red Hat Enterprise Linux 5 has reached the end of Production 1 Phase of its Life Cycle.  Red Hat does not plan to incorporate the suggested capability in a future Red Hat Enterprise Linux 5 minor release. If you would like Red  Hat to re-consider this feature request and the requested functionality is not currently in Red Hat Enterprise Linux 6, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.