Bug 458343 - ifup-eth0 no support for ip addr pointopointdirective
ifup-eth0 no support for ip addr pointopointdirective
Status: CLOSED DUPLICATE of bug 488389
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 14:01 EDT by fedora
Modified: 2014-03-16 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 17:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fedora 2008-08-07 14:01:14 EDT
Description of problem:
In some environments with VLAN switches, a server node should be configured to be alone (= netmask /32). This is not supportet by /etc/sysconfig/network-scripts/ifcfg-eth0.

In order to reach its default gateway, there must be a host route to that default gateway first, because there's no more subnetwork route (because /32 mask).

When configuring this manually, it is easy with (10.1.1.1 = default gateway):

ifconfig eth0 pointopoint 10.1.1.1 netmask 255.255.255.255 broadcast 10.255.255.255

"ifconfig" or "ip" own a "pointopoint" directive similar to ppp configuration. This "pointopoint" tells ifconfig/ip to create the host route to the default gateway before setting it as default route.

Version-Release number of selected component (if applicable):
initscripts-8.76.2-1.i386

How reproducible:
set NETMASK=255.255.255.255 in /etc/sysconfig/network-scripts/ifcfg-eth0. Then the default route could not be set.

Steps to Reproduce:
1. set NETMASK=255.255.255.255 in /etc/sysconfig/network-scripts/ifcfg-eth0
2. service network restart
3.
  
Actual results:
No more default route, no more internet connection.

Expected results:
/etc/sysconfig/network-scripts/ifup-eth should use "pointopoint" for setting
ifconfig eth0 pointopoint 10.1.1.1...

Additional info:
Comment 1 Bill Nottingham 2009-03-20 17:09:50 EDT

*** This bug has been marked as a duplicate of bug 488389 ***

Note You need to log in before you can comment on or make changes to this bug.