Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 458353 - Openoffice thumbnails fail
Summary: Openoffice thumbnails fail
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgsf
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-07 18:47 UTC by Michael Wise
Modified: 2008-08-08 13:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-08 13:19:02 UTC
Type: ---


Attachments (Terms of Use)

Description Michael Wise 2008-08-07 18:47:18 UTC
Description of problem: Thumbnails of all openoffice documents are not being created.  Whenever I create a new document or move one, a png file gets created in $HOME/.thumbnails/fail/gnome-thumbnail-factory and the icon stays the default for the mime type


Version-Release number of selected component (if applicable):

openoffice.org-core-2.4.1-17.4.fc9.i386
libgsf-1.14.8-1.fc9.i386

How reproducible: It happens all the time.  Whether a new do


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Caolan McNamara 2008-08-08 07:55:48 UTC
This seems to work for me, so lets try and do it manually and see where it goes wrong...

Take a sample document that doesn't work and first try...

a)
mkdir /tmp/foo
cd /tmp/foo
unzip /path/to/sample.odt
gthumb Thumbnails/thumbnail.png

and see if there is a thumbnail, and if it is viewable. If that works then...

b)
gsf-office-thumbnailer -i /path/to/sample.odt -o foo.png -s 300
gthumb foo.png

and see if that works

Comment 2 Michael Wise 2008-08-08 10:42:35 UTC
I unzipped the document and was able to view the thumbnail (was not able to read it even when zoomed in). I ran gsf-office-thumbnailer and this is what I got

$ gsf-office-thumbnailer -i Network\ Survey\ Checklist.odt -o foo.png -s 300
calling convert 'foo.png.C9MPFU' +matte -thumbnail 300x300 png:'foo.png'
error: Failed to execute child process "convert" (No such file or directory)

It created the foo.png.C9MPFU file that was viewable but unreadable.

Comment 3 Caolan McNamara 2008-08-08 11:43:35 UTC
Aha, so what I think we have here is a missing dependency on ImageMagick on that /usr/bin/gsf-office-thumbnailer

if you install ImageMagick does it "work" again ?

Comment 4 Michael Wise 2008-08-08 12:57:24 UTC
Yep, that fixed it.  I didn't think to see if anything provided "convert".  I appreciate you getting to this so quick.  It really wasn't that important.  Just something minor that wasn't working.

Comment 5 Caolan McNamara 2008-08-08 13:19:02 UTC
Fixed in rawhide by moving the convert tool to the gnome subpackage and adding a dependency on ImageMagick.


Note You need to log in before you can comment on or make changes to this bug.