Bug 458400 - Bad keyboard layout (no arrow keys, home/end, etc)
Bad keyboard layout (no arrow keys, home/end, etc)
Status: CLOSED DUPLICATE of bug 460550
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 20:18 EDT by Stewart Adam
Modified: 2014-01-12 19:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-17 11:07:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2008-08-07 20:18:33 EDT
Description of problem:
When using the command line (outside Xorg), I think the keyboard is incorrectly detected although this may not be the actual problem. In any case, the arrow keys don't function at all (cursor doesn't move, no output) and neither does the whole set of keys in between the keyboard and the numpad such as home/end/ or page up/down. I have to resort to turning off numlock and using those are the arrow keys, which does work.

Version-Release number of selected component (if applicable):
bash-3.2-27.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Ctrl+Alt+F1
2. Try to use the arrow keys
  
Actual results:
Nothing happens (like the keys aren't detected or mapped)

Expected results:
Keys work

Additional info:
Comment 1 Andreas M. Kirchwitz 2008-09-17 09:43:31 EDT
Bug #460550 describes a similar (the same?) problem.

I'm not using Rawhide but regular Fedora 8, and I have the same problem
after updating from kernel 2.6.25 to kernel 2.6.26. For me, hitting the
"Insert" key once, temporarily makes cursor keys etc. work. But only for
a limited time.
Comment 2 Roman Rakus 2008-09-17 10:55:51 EDT
I think, the same problem. If the arrow keys works inside Xorg and not outside Xorg, it is not bug in bash. Probably it is the same as Bug #460550.
Comment 3 Roman Rakus 2008-09-17 11:07:56 EDT

*** This bug has been marked as a duplicate of bug 460550 ***

Note You need to log in before you can comment on or make changes to this bug.